CVE-2022-2421 is a critical-severity (CVSS 10) SQL Injection vulnerability in socket.io-parser. A fix is available for socket.io-parser — see the affected versions and patch details below.
Socket.io - Improper type validation in attachment parsing
Exploitation Status
No confirmed exploitation observed yet
- CISA assesses this as automatable — exploitation doesn’t require manual, per-target effort, which raises the odds of mass scanning and opportunistic attacks.
- A successful exploit gives an attacker total control of the affected component, not partial access.
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for CVE-2022-2421.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
How broadly this vulnerability is actually deployed: weekly install volume shows current usage, and reverse-dependency count shows how many other packages break if it stays unpatched.
socket.io-parsernpmDescription
Due to improper type validation in the socket.io-parser library (which is used by the socket.io and socket.io-client packages to encode and decode Socket.IO packets), it is possible to overwrite the _placeholder object which allows an attacker to place references to functions at arbitrary places in the resulting query object.
Example:
const decoder = new Decoder();
decoder.on("decoded", (packet) => {
console.log(packet.data); // prints [ 'hello', [Function: splice] ]
})
decoder.add('51-["hello",{"_placeholder":true,"num":"splice"}]');
decoder.add(Buffer.from("world"));
This bubbles up in the socket.io package:
io.on("connection", (socket) => {
socket.on("hello", (val) => {
// here, "val" could be a function instead of a buffer
});
});
:warning: IMPORTANT NOTE :warning:
You need to make sure that the payload that you received from the client is actually a Buffer object:
io.on("connection", (socket) => {
socket.on("hello", (val) => {
if (!Buffer.isBuffer(val)) {
socket.disconnect();
return;
}
// ...
});
});
If that's already the case, then you are not impacted by this issue, and there is no way an attacker could make your server crash (or escalate privileges, ...).
Example of values that could be sent by a malicious user:
- a number that is out of bounds
Sample packet: 451-["hello",{"_placeholder":true,"num":10}]
io.on("connection", (socket) => {
socket.on("hello", (val) => {
// val is `undefined`
});
});
- a value that is not a number, like
undefined
Sample packet: 451-["hello",{"_placeholder":true,"num":undefined}]
io.on("connection", (socket) => {
socket.on("hello", (val) => {
// val is `undefined`
});
});
- a string that is part of the prototype of
Array, like "push"
Sample packet: 451-["hello",{"_placeholder":true,"num":"push"}]
io.on("connection", (socket) => {
socket.on("hello", (val) => {
// val is a reference to the "push" function
});
});
- a string that is part of the prototype of
Object, like "hasOwnProperty"
Sample packet: 451-["hello",{"_placeholder":true,"num":"hasOwnProperty"}]
io.on("connection", (socket) => {
socket.on("hello", (val) => {
// val is a reference to the "hasOwnProperty" function
});
});
This should be fixed by:
- https://github.com/socketio/socket.io-parser/commit/b5d0cb7dc56a0601a09b056beaeeb0e43b160050, included in
[email protected] - https://github.com/socketio/socket.io-parser/commit/b559f050ee02bd90bd853b9823f8de7fa94a80d4, included in
[email protected] - https://github.com/socketio/socket.io-parser/commit/04d23cecafe1b859fb03e0cbf6ba3b74dff56d14, included in
[email protected] - https://github.com/socketio/socket.io-parser/commit/fb21e422fc193b34347395a33e0f625bebc09983, included in
[email protected]
Dependency analysis for the socket.io package
socket.io version | socket.io-parser version | Covered? |
|---|---|---|
4.5.2...latest | ~4.2.0 (ref) | Yes :heavy_check_mark: |
4.1.3...4.5.1 | ~4.0.4 (ref) | Yes :heavy_check_mark: |
3.0.5...4.1.2 | ~4.0.3 (ref) | Yes :heavy_check_mark: |
3.0.0...3.0.4 | ~4.0.1 (ref) | Yes :heavy_check_mark: |
2.3.0...2.5.0 | ~3.4.0 (ref) | Yes :heavy_check_mark: |
Dependency analysis for the socket.io-client package
socket.io-client version | socket.io-parser version | Covered? |
|---|---|---|
4.5.0...latest | ~4.2.0 (ref) | Yes :heavy_check_mark: |
4.3.0...4.4.1 | ~4.1.1 (ref) | No, but the impact is very limited |
3.1.0...4.2.0 | ~4.0.4 (ref) | Yes :heavy_check_mark: |
3.0.5 | ~4.0.3 (ref) | Yes :heavy_check_mark: |
3.0.0...3.0.4 | ~4.0.1 (ref) | Yes :heavy_check_mark: |
2.2.0...2.5.0 | ~3.3.0 (ref) | Yes :heavy_check_mark: |
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 📦npm | socket.io-parser | ≥ 4.0.0&&< 4.0.5 | 4.0.5npm install socket.io-parser@4.0.5 |
| 📦npm | socket.io-parser | ≥ 4.1.0&&< 4.2.1 | 4.2.1npm install socket.io-parser@4.2.1 |
| 📦npm | socket.io-parser | all versions | 3.3.3npm install socket.io-parser@3.3.3 |
| 📦npm | socket.io-parser | ≥ 3.4.0&&< 3.4.2 | 3.4.2npm install socket.io-parser@3.4.2 |
Affected Products
socket.io-parsersocketDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for socket.io-parser, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update socket.io-parser to 4.0.5 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2022-2421 is resolved across your whole dependency graph.
Workarounds
Until you can upgrade, make sure every query built from user input uses parameterised statements or a prepared-statement API rather than string concatenation, and reduce the database account's privileges so an injected query cannot read or alter data beyond what the feature needs.
Frequently Asked Questions
Is CVE-2022-2421 in your dependencies?
Find it across npm, including transitive dependencies.