CVE-2026-69185 is a high-severity (CVSS 7.5) Improper Input Validation vulnerability in socket.io-parser. A fix is available for socket.io-parser — see the affected versions and patch details below.
Socket.IO: Zero-attachment Memory Exhaustion
Exploitation Status
No confirmed exploitation observed yet
- CISA assesses this as automatable — exploitation doesn’t require manual, per-target effort, which raises the odds of mass scanning and opportunistic attacks.
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for CVE-2026-69185.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
How broadly this vulnerability is actually deployed: weekly install volume shows current usage, and reverse-dependency count shows how many other packages break if it stays unpatched.
socket.io-parsernpmDescription
Impact
A specially crafted Socket.IO packet can make the server wait for a large number of binary attachments and buffer them, which can be exploited to make the server run out of memory.
Patches
| Version range | Used by | Fixed version |
|---|---|---|
>=4.0.0 <4.2.7 | [email protected] and [email protected] | 4.2.7 |
>=3.4.0 <3.4.5 | [email protected] | 3.4.5 |
<3.3.6 | [email protected] | 3.3.6 |
Workarounds
There is no known workaround except upgrading to a safe version.
For more information
If you have any questions or comments about this advisory:
- Open a discussion here
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 📦npm | socket.io-parser | ≥ 4.0.0&&< 4.2.7 | 4.2.7npm install socket.io-parser@4.2.7 |
| 📦npm | socket.io-parser | ≥ 3.4.0&&< 3.4.5 | 3.4.5npm install socket.io-parser@3.4.5 |
| 📦npm | socket.io-parser | all versions | 3.3.6npm install socket.io-parser@3.3.6 |
Detection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for socket.io-parser, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update socket.io-parser to 4.2.7 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2026-69185 is resolved across your whole dependency graph.
Workarounds
If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.
Frequently Asked Questions
Is CVE-2026-69185 in your dependencies?
Find it across npm, including transitive dependencies.