CVE-2023-32695 is a high-severity (CVSS 7.3) Improper Input Validation vulnerability in socket.io-parser. A fix is available for socket.io-parser — see the affected versions and patch details below.
Insufficient validation when decoding a Socket.IO packet
Exploitation Status
No confirmed exploitation observed yet
- CISA assesses this as automatable — exploitation doesn’t require manual, per-target effort, which raises the odds of mass scanning and opportunistic attacks.
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for CVE-2023-32695.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
How broadly this vulnerability is actually deployed: weekly install volume shows current usage, and reverse-dependency count shows how many other packages break if it stays unpatched.
socket.io-parsernpmDescription
Impact
A specially crafted Socket.IO packet can trigger an uncaught exception on the Socket.IO server, thus killing the Node.js process.
TypeError: Cannot convert object to primitive value
at Socket.emit (node:events:507:25)
at .../node_modules/socket.io/lib/socket.js:531:14
Patches
A fix has been released today (2023/05/22):
- https://github.com/socketio/socket.io-parser/commit/3b78117bf6ba7e99d7a5cfc1ba54d0477554a7f3, included in
[email protected] - https://github.com/socketio/socket.io-parser/commit/2dc3c92622dad113b8676be06f23b1ed46b02ced, included in
[email protected]
Another fix has been released for the 3.3.x branch:
- https://github.com/socketio/socket.io-parser/commit/ee006607495eca4ec7262ad080dd3a91439a5ba4, included in `[email protected]
socket.io version | socket.io-parser version | Needs minor update? |
|---|---|---|
4.5.2...latest | ~4.2.0 (ref) | npm audit fix should be sufficient |
4.1.3...4.5.1 | ~4.1.1 (ref) | Please upgrade to [email protected] |
3.0.5...4.1.2 | ~4.0.3 (ref) | Please upgrade to [email protected] |
3.0.0...3.0.4 | ~4.0.1 (ref) | Please upgrade to [email protected] |
2.3.0...2.5.0 | ~3.4.0 (ref) | npm audit fix should be sufficient |
Workarounds
There is no known workaround except upgrading to a safe version.
For more information
If you have any questions or comments about this advisory:
- Open a discussion here
Thanks to @rafax00 for the responsible disclosure.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 📦npm | socket.io-parser | ≥ 4.0.4&&< 4.2.3 | 4.2.3npm install socket.io-parser@4.2.3 |
| 📦npm | socket.io-parser | ≥ 3.4.0&&< 3.4.3 | 3.4.3npm install socket.io-parser@3.4.3 |
| 📦npm | socket.io-parser | all versions | 3.3.4npm install socket.io-parser@3.3.4 |
Affected Products
socket.io-parsersocketDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for socket.io-parser, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update socket.io-parser to 4.2.3 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2023-32695 is resolved across your whole dependency graph.
Workarounds
If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.
Frequently Asked Questions
Is CVE-2023-32695 in your dependencies?
Find it across npm, including transitive dependencies.