CVE-2012-2395 — cobbler
Fix: cobbler/cobbler@6d9167eCVE-2012-2395 is a remote code execution vulnerability in cobbler. 1 public exploit or proof-of-concept reference is indexed, so weaponization risk is real. A fix is available for cobbler — see the affected versions and patch details below.
Cobbler subject to Command Injection
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
Real-World Exposure
cobblerReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects PyPI packages — download data is not available via public APIs for these ecosystems.
Description
Incomplete blacklist vulnerability in action_power.py in Cobbler 2.2.0 allows remote attackers to execute arbitrary commands via shell metacharacters in the (1) username or (2) password fields to the power_system method in the xmlrpc API.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐍PyPI | cobbler | all versions | 2.6.0pip install --upgrade 'cobbler==2.6.0' |
Affected Products
cobblermichael_dehaanResearch use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.
Detection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for cobbler, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update cobbler to 2.6.0 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2012-2395 is resolved across your whole dependency graph.
Workarounds
Stop passing untrusted input into the interpreter or shell: call the affected binary with an argument array rather than a composed command string, reject anything outside a strict allowlist of expected values, and run the component under an account that cannot reach beyond the work it legitimately does.
Fixing This On Your OS
If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.
This issue did not affect the version of cobbler as shipped with Red Hat Network Satellite Server 5.3.0, as it did not include the upstream commit 0e5f6f2d50d460f4c6b0c9f62cfed0ff5c546906 that introduced this flaw. This issue affects the version of cobbler as shipped with Red Hat Network Satellite Server 5.4.0.
| Product | Fixed in | Advisory |
|---|---|---|
| Red Hat Network Satellite Server v 5.4 | cobbler-0:2.0.7-14.6.el5sat | RHSA-2012:1060 |
Frequently Asked Questions
Is CVE-2012-2395 in your dependencies?
Find it across PyPI, including transitive dependencies.