NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐍 PyPI
Not in CISA KEV

CVE-2014-3225 — cobbler

Fix: cobbler/cobbler@8232c0e

CVE-2014-3225 is a Path Traversal vulnerability in cobbler. 4 public exploit or proof-of-concept references are indexed, so weaponization risk is real. A fix is available for cobbler — see the affected versions and patch details below.

Cobbler Path Traversal vulnerability

Also known asPYSEC-2026-797
Published
Updated
Affected
2 pkgs
Patched
2 / 2
Exploits
4 known
Exploitation data as of Nov 4, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
8.9%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs95th percentile — riskier than 95% of all scored CVEsHighest risk
5.28%6.76%8.24%9.71%6.1%8.9%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

Real-World Exposure

2 pkgs affected
🐍cobbler🐍cobbler

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects PyPI packages — download data is not available via public APIs for these ecosystems.

Description

Absolute path traversal vulnerability in the web interface in Cobbler 2.4.x through 2.6.x allows remote authenticated users to read arbitrary files via the Kickstart field in a profile.

Affected Packages

2 total 2 fixed
EcosystemPackageVulnerable rangeFix
🐍PyPIcobbler≥ 2.6.0&&< 2.6.42.6.4pip install --upgrade 'cobbler==2.6.4'
🐍PyPIcobbler≥ 2.4.0&&< 2.4.72.4.7pip install --upgrade 'cobbler==2.4.7'

Affected Products

1 product · 7 configurations
Application
cobblercobblerd
6 versions
2.4.02.4.12.4.22.4.32.4.42.6.0
Exploits & PoCs
4

Research use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.

EDB-33252webappsphp

Cobbler 2.4.x < 2.6.x - Local File Inclusion

by Dolev Farhi · May 8, 2014

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for cobbler, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update cobbler to 2.6.4 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2014-3225 is resolved across your whole dependency graph.

  3. Workarounds

    Resolve every user-supplied path to its canonical form and reject anything that escapes the intended directory, and run the component under an account that has no read or write access outside the directory it legitimately serves.

Frequently Asked Questions

Absolute path traversal vulnerability in the web interface in Cobbler 2.4.x through 2.6.x allows remote authenticated users to read arbitrary files via the Kickstart field in a profile.
O3 Security · Impact-Aware SCA

Is CVE-2014-3225 in your dependencies?

Find it across PyPI, including transitive dependencies.

CVE-2014-3225: cobbler Path Traversal — Fixed in 2.6.4