NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐍 PyPI
Not in CISA KEV

CVE-2008-6954 — cobbler

CVE-2008-6954 is a CWE-264 vulnerability in cobbler. A fix is available for cobbler — see the affected versions and patch details below.

Cobbler Web Interface Kickstart Template Remote Privilege Escalation Vulnerability

Also known asPYSEC-2026-795
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
None indexed
Exploitation data as of Nov 5, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
2.2%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs82th percentile — riskier than 82% of all scored CVEsHighest risk
1.14%1.65%2.15%2.66%1.6%2.2%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

Real-World Exposure

1 pkg affected
🐍cobbler

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects PyPI packages — download data is not available via public APIs for these ecosystems.

Description

The web interface (CobblerWeb) in Cobbler before 1.2.9 allows remote authenticated users to execute arbitrary Python code with the root privileges in cobblerd by editing a Cheetah kickstart template to import arbitrary Python modules.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
🐍PyPIcobblerall versions1.2.9pip install --upgrade 'cobbler==1.2.9'

Affected Products

1 product · 42 configurations
Application
cobblermichael_dehaan
≤ 1.2.8
41 versions
0.1.1.70.2.10.2.20.2.30.2.50.2.70.2.80.2.90.3.00.3.10.3.30.3.4

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for cobbler, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update cobbler to 1.2.9 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2008-6954 is resolved across your whole dependency graph.

  3. Workarounds

    If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.

Frequently Asked Questions

The web interface (CobblerWeb) in Cobbler before 1.2.9 allows remote authenticated users to execute arbitrary Python code with the root privileges in cobblerd by editing a Cheetah kickstart template to import arbitrary Python modules.
O3 Security · Impact-Aware SCA

Is CVE-2008-6954 in your dependencies?

Find it across PyPI, including transitive dependencies.

CVE-2008-6954: cobbler — Fixed in 1.2.9