NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐍 PyPI
Not in CISA KEV

CVE-2010-2235 — cobbler

CVE-2010-2235 is a Code Injection vulnerability in cobbler. A fix is available for cobbler — see the affected versions and patch details below.

Cobbler is vulnerable to code injection

Also known asPYSEC-2026-794
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
None indexed
Exploitation data as of Nov 4, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
3.3%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs89th percentile — riskier than 89% of all scored CVEsHighest risk
1.34%2.18%3.02%3.85%1.8%3.3%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

Real-World Exposure

1 pkg affected
🐍cobbler

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects PyPI packages — download data is not available via public APIs for these ecosystems.

Description

template_api.py in Cobbler before 2.0.7, as used in Red Hat Network Satellite Server and other products, does not disable the ability of the Cheetah template engine to execute Python statements contained in templates, which allows remote authenticated administrators to execute arbitrary code via a crafted kickstart template file, a different vulnerability than CVE-2008-6954.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
🐍PyPIcobblerall versions2.0.7pip install --upgrade 'cobbler==2.0.7'

Affected Products

1 product · 82 configurations
Application
cobblermichael_dehaan
≤ 2.0.4
81 versions
0.1.1.70.2.10.2.20.2.30.2.50.2.70.2.80.2.90.3.00.3.10.3.30.3.4

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for cobbler, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update cobbler to 2.0.7 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2010-2235 is resolved across your whole dependency graph.

  3. Workarounds

    Stop passing untrusted input into the interpreter or shell: call the affected binary with an argument array rather than a composed command string, reject anything outside a strict allowlist of expected values, and run the component under an account that cannot reach beyond the work it legitimately does.

Fixing This On Your OS

If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.

Red HatImportant
ProductFixed inAdvisory
Red Hat Network Satellite Server v 5.3cobbler-0:1.6.6-15.el4satRHSA-2010:0775

Frequently Asked Questions

template_api.py in Cobbler before 2.0.7, as used in Red Hat Network Satellite Server and other products, does not disable the ability of the Cheetah template engine to execute Python statements contained in templates, which allows remote authenticated administrators to execute arbitrary code via a crafted kickstart template file, a different vulnerability than CVE-2008-6954.
O3 Security · Impact-Aware SCA

Is CVE-2010-2235 in your dependencies?

Find it across PyPI, including transitive dependencies.

CVE-2010-2235: cobbler RCE — Fixed in 2.0.7