CVE-2022-0860 is a high-severity (CVSS 8.2) CWE-285 vulnerability in cobbler. 1 public exploit or proof-of-concept reference is indexed, so weaponization risk is real. A fix is available for cobbler — see the affected versions and patch details below.
Improper Authorization in cobbler/cobbler
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
cobblerReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects PyPI packages — download data is not available via public APIs for these ecosystems.
Description
Impact
If PAM is correctly configured and a user account is set to expired, the expired user-account is still able to successfully log into Cobbler in all places (Web UI, CLI & XMLRPC-API).
The same applies to user accounts with passwords set to be expired.
Patches
There is a patch for the latest Cobbler 3.3.2 available, however a backport will be done for 3.2.x.
Workarounds
- Delete expired accounts which are able to access Cobbler via PAM.
- Use
chage -l <username>to lock the account. If the account has SSH-Keys attached then remove them completely.
References
- Originally discovered by @ysf at https://www.huntr.dev/bounties/c458b868-63df-414e-af10-47e3745caa1d/
How to test if my Cobbler instance is affected?
The following pytest test assumes that your PAM setup is correct. In case the added user is not able to login, this test does not make sense to be executed.
def test_pam_login_with_expired_user():
# Arrange
# create pam testuser
test_username = "expired_user"
test_password = "password"
test_api = CobblerAPI()
subprocess_1 = subprocess.run(
["perl", "-e", "'print crypt(\"%s\", \"%s\")'" % (test_username, test_password)],
stdout=subprocess.PIPE
)
subprocess.run(["useradd", "-p", subprocess_1.stdout, test_username])
# change user to be expired
subprocess.run(["chage", "-E0", test_username])
# Act
result = pam.authenticate(test_api, test_username, test_password)
# Assert - login should fail
assert not result
For more information
If you have any questions or comments about this advisory:
- Open an issue in the Cobbler repository
- Ask in the Gitter/Matrix Chat
- Email us at [email protected]
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐍PyPI | cobbler | all versions | 3.3.2pip install --upgrade 'cobbler==3.3.2' |
Affected Products
cobblercobbler_projectfedorafedoraprojectResearch use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.
Detection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for cobbler, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update cobbler to 3.3.2 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2022-0860 is resolved across your whole dependency graph.
Workarounds
Put an independent control in front of the weakness: restrict the affected endpoint or interface to trusted networks, require an additional authentication factor or proxy-level check, and invalidate existing sessions and credentials in case the flaw has already been used.
Frequently Asked Questions
Is CVE-2022-0860 in your dependencies?
Find it across PyPI, including transitive dependencies.