NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐘
🐘 Packagist
Not in CISA KEV
CRITICAL severity

CVE-2014-8089 — zendframework1

CRITICAL

CVE-2014-8089 is a critical-severity (CVSS 9.8) SQL Injection vulnerability in zendframework/zendframework1. 1 public exploit or proof-of-concept reference is indexed, so weaponization risk is real. A fix is available for zendframework/zendframework1 — see the affected versions and patch details below.

Zend Framework SQL injection vulnerability

Published
Updated
Affected
9 pkgs
Patched
9 / 9
Exploits
1 known
Exploitation data as of Oct 30, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
2.5%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs85th percentile — riskier than 85% of all scored CVEsHighest risk
0.62%1.43%2.24%3.05%1.1%2.5%Apr 26Aug 26Oct 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

9 pkgs affected
🐘zendframework/zendframework1🐘zendframework/zend-db🐘zendframework/zend-db🐘zendframework/zend-db🐘zendframework/zend-db🐘zendframework/zendframework🐘zendframework/zendframework🐘zendframework/zendframework+1 more

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.

Description

SQL injection vulnerability in Zend Framework before 1.12.9, 2.2.x before 2.2.8, and 2.3.x before 2.3.3, when using the sqlsrv PHP extension, allows remote attackers to execute arbitrary SQL commands via a null byte.

Affected Packages

9 total 9 fixed
EcosystemPackageVulnerable rangeFix
🐘Packagistzendframework/zendframework1≥ 1.12.0&&< 1.12.91.12.9composer require zendframework/zendframework1:^1.12.9
🐘Packagistzendframework/zend-db≥ 2.0.0&&< 2.0.992.0.99composer require zendframework/zend-db:^2.0.99
🐘Packagistzendframework/zend-db≥ 2.1.0&&< 2.1.992.1.99composer require zendframework/zend-db:^2.1.99
🐘Packagistzendframework/zend-db≥ 2.2.0&&< 2.2.82.2.8composer require zendframework/zend-db:^2.2.8
🐘Packagistzendframework/zend-db≥ 2.3.0&&< 2.3.32.3.3composer require zendframework/zend-db:^2.3.3
🐘Packagistzendframework/zendframework≥ 2.0.0&&< 2.0.992.0.99composer require zendframework/zendframework:^2.0.99

Affected Products

3 products · 8 configurations
OS
fedorafedoraproject
3 versions
192021
OS
enterprise linuxredhat
2 versions
6.07.0
Application
zend frameworkzend
≥ 2.3.0 && < 2.3.3
range
Exploits & PoCs
1

Research use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for zendframework/zendframework1, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update zendframework/zendframework1 to 1.12.9 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2014-8089 is resolved across your whole dependency graph.

  3. Workarounds

    Until you can upgrade, make sure every query built from user input uses parameterised statements or a prepared-statement API rather than string concatenation, and reduce the database account's privileges so an injected query cannot read or alter data beyond what the feature needs.

Frequently Asked Questions

SQL injection vulnerability in Zend Framework before 1.12.9, 2.2.x before 2.2.8, and 2.3.x before 2.3.3, when using the sqlsrv PHP extension, allows remote attackers to execute arbitrary SQL commands via a null byte.
O3 Security · Impact-Aware SCA

Is CVE-2014-8089 in your dependencies?

Find it across Packagist, including transitive dependencies.

CVE-2014-8089: zendframework1 — Fixed in 1.12.9