CVE-2012-6531 — zendframework1
Fix: zendframework/zf1@1b5e861CVE-2012-6531 is a Improper Input Validation vulnerability in zendframework/zendframework1. A fix is available for zendframework/zendframework1 — see the affected versions and patch details below.
Zend Framework XEE Vulnerability
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
Real-World Exposure
zendframework/zendframework1🐘zendframework/zendframework1Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.
Description
(1) Zend_Dom, (2) Zend_Feed, and (3) Zend_Soap in Zend Framework 1.x before 1.11.13 and 1.12.x before 1.12.0 do not properly handle SimpleXMLElement classes, which allow remote attackers to read arbitrary files or create TCP connections via an external entity reference in a DOCTYPE element in an XML-RPC request, aka an XML external entity (XXE) injection attack, a different vulnerability than CVE-2012-3363.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐘Packagist | zendframework/zendframework1 | ≥ 1.0&&< 1.11.13 | 1.11.13composer require zendframework/zendframework1:^1.11.13 |
| 🐘Packagist | zendframework/zendframework1 | ≥ 1.12.0-rc1&&< 1.12.0 | 1.12.0composer require zendframework/zendframework1:^1.12.0 |
Affected Products
zend frameworkzendDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for zendframework/zendframework1, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update zendframework/zendframework1 to 1.11.13 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2012-6531 is resolved across your whole dependency graph.
Workarounds
If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.
Frequently Asked Questions
Is CVE-2012-6531 in your dependencies?
Find it across Packagist, including transitive dependencies.