CVE-2012-3363 is a high-severity (CVSS 7.3) XML External Entity (XXE) vulnerability in zendframework/zendframework1. 1 public exploit or proof-of-concept reference is indexed, so weaponization risk is real. A fix is available for zendframework/zendframework1 — see the affected versions and patch details below.
Zend Framework XXE Vulnerability
Exploitation Status
No confirmed exploitation observed yet
- CISA assesses this as automatable — exploitation doesn’t require manual, per-target effort, which raises the odds of mass scanning and opportunistic attacks.
- A successful exploit gives an attacker total control of the affected component, not partial access.
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for CVE-2012-3363.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
zendframework/zendframework1🐘zendframework/zendframework1Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.
Description
Zend_XmlRpc in Zend Framework 1.x before 1.11.12 and 1.12.x before 1.12.0 does not properly handle SimpleXMLElement classes, which allows remote attackers to read arbitrary files or create TCP connections via an external entity reference in a DOCTYPE element in an XML-RPC request, aka an XML external entity (XXE) injection attack.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐘Packagist | zendframework/zendframework1 | ≥ 1.0.0&&< 1.11.12 | 1.11.12composer require zendframework/zendframework1:^1.11.12 |
| 🐘Packagist | zendframework/zendframework1 | ≥ 1.12.0-rc1&&< 1.12.0 | 1.12.0composer require zendframework/zendframework1:^1.12.0 |
Affected Products
debian linuxdebianfedorafedoraprojectzend frameworkzendResearch use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.
Zend Framework < 2.0.0 beta4 < 1.12 RC1 < 1.11.11 - Local File Disclosure
by SEC Consult · Jun 27, 2012
Detection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for zendframework/zendframework1, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update zendframework/zendframework1 to 1.11.12 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2012-3363 is resolved across your whole dependency graph.
Workarounds
If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.
Frequently Asked Questions
Is CVE-2012-3363 in your dependencies?
Find it across Packagist, including transitive dependencies.