RubyGems vulnerable to DNS hijack attackGHSA-wp3j-rvfp-624h
GHSA-wp3j-rvfp-624h is a CWE-254 vulnerability in rubygems-update. A fix is available for rubygems-update — see the affected versions and patch details below.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
Real-World Exposure
rubygems-update💎rubygems-update💎rubygems-updateReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects RubyGems packages — download data is not available via public APIs for these ecosystems.
Description
RubyGems 2.0.x before 2.0.16, 2.2.x before 2.2.4, and 2.4.x before 2.4.7 does not validate the hostname when fetching gems or making API requests, which allows remote attackers to redirect requests to arbitrary domains via a crafted DNS SRV record, aka a "DNS hijack attack."
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 💎RubyGems | rubygems-update | ≥ 2.0.0&&< 2.0.16 | 2.0.16bundle update rubygems-update --conservative |
| 💎RubyGems | rubygems-update | ≥ 2.2.0&&< 2.2.4 | 2.2.4bundle update rubygems-update --conservative |
| 💎RubyGems | rubygems-update | ≥ 2.4.0&&< 2.4.7 | 2.4.7bundle update rubygems-update --conservative |
Affected Products
solarisoracleenterprise linuxredhatrubyruby-langrubygemsrubygemsDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for rubygems-update, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update rubygems-update to 2.0.16 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-wp3j-rvfp-624h is resolved across your whole dependency graph.
Workarounds
If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.
Fixing This On Your OS
If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.
This issue did not affect the versions of rubygems as shipped with Red Hat Enterprise Linux 6, Red Hat Enterprise MRG 2.5, Red Hat Satellite 6, Red Hat Openstack 5, Red Hat Openshift Enterprise 2 as they did not include support for getting API endpoint using SRV DNS records. This issue did not affect the versions of…
| Product | Fixed in | Advisory |
|---|---|---|
| Red Hat Software Collections for Red Hat Enterprise Linux 6 | rh-ruby22-ruby-0:2.2.2-12.el6 | RHSA-2015:1657 |
Frequently Asked Questions
Is GHSA-wp3j-rvfp-624h in your dependencies?
Find it across RubyGems, including transitive dependencies.