NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
💎 RubyGems
Not in CISA KEV

CVE-2012-2125 — rubygems-update

CVE-2012-2125 is a security vulnerability in rubygems-update. A fix is available for rubygems-update — see the affected versions and patch details below.

RubyGems HTTPS to HTTP redirect

Also known asGHSA-228f-g3h7-3fj3
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
None indexed
Exploitation data as of Nov 6, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
2.5%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs85th percentile — riskier than 85% of all scored CVEsHighest risk
0.09%1.07%2.05%3.03%0.6%2.5%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

Real-World Exposure

1 pkg affected
💎rubygems-update

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects RubyGems packages — download data is not available via public APIs for these ecosystems.

Description

RubyGems before 1.8.23 can redirect HTTPS connections to HTTP, which makes it easier for remote attackers to observe or modify a gem during installation via a man-in-the-middle attack.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
💎RubyGemsrubygems-updateall versions1.8.23bundle update rubygems-update --conservative

Affected Products

1 product · 23 configurations
Application
rubygemsrubygems
≤ 1.8.22
22 versions
1.8.01.8.11.8.21.8.31.8.41.8.51.8.61.8.71.8.81.8.91.8.101.8.11

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for rubygems-update, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update rubygems-update to 1.8.23 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2012-2125 is resolved across your whole dependency graph.

  3. Workarounds

    If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.

Fixing This On Your OS

If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.

Red HatModerate

The Red Hat Security Response Team has rated this issue as having moderate security impact in CloudForms 1.1. This issue is not currently planned to be addressed in future updates.

ProductFixed inAdvisory
Red Hat Enterprise Linux 6rubygems-0:1.3.7-4.el6_4RHSA-2013:1441
Red Hat Enterprise MRG 2cumin-0:0.1.5787-4.el6RHSA-2013:1852
RHEL 6 Version of OpenShift Enterprise 1.2rubygems-0:1.8.24-4.el6opRHSA-2013:1203

Frequently Asked Questions

RubyGems before 1.8.23 can redirect HTTPS connections to HTTP, which makes it easier for remote attackers to observe or modify a gem during installation via a man-in-the-middle attack.
O3 Security · Impact-Aware SCA

Is CVE-2012-2125 in your dependencies?

Find it across RubyGems, including transitive dependencies.

CVE-2012-2125: rubygems-update — Fixed in 1.8.23