NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
💎 RubyGems
Not in CISA KEV

CVE-2013-4363 — rubygems-update

CVE-2013-4363 is a CWE-310 vulnerability in rubygems-update. A fix is available for rubygems-update — see the affected versions and patch details below.

RubyGems Regular Expression Denial of Service

Also known asGHSA-9qvm-2vhf-q649
Published
Updated
Affected
4 pkgs
Patched
4 / 4
Exploits
None indexed
Exploitation data as of Nov 5, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
1.7%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs77th percentile — riskier than 77% of all scored CVEsHighest risk
0.09%0.79%1.49%2.19%0.6%1.7%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

Real-World Exposure

4 pkgs affected
💎rubygems-update💎rubygems-update💎rubygems-update💎rubygems-update

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects RubyGems packages — download data is not available via public APIs for these ecosystems.

Description

Algorithmic complexity vulnerability in Gem::Version::ANCHORED_VERSION_PATTERN in lib/rubygems/version.rb in RubyGems before 1.8.23.2, 1.8.24 through 1.8.26, 2.0.x before 2.0.10, and 2.1.x before 2.1.5, as used in Ruby 1.9.0 through 2.0.0p247, allows remote attackers to cause a denial of service (CPU consumption) via a crafted gem version that triggers a large amount of backtracking in a regular expression. NOTE: this issue is due to an incomplete fix for CVE-2013-4287.

Affected Packages

4 total 4 fixed
EcosystemPackageVulnerable rangeFix
💎RubyGemsrubygems-updateall versions1.8.23.2bundle update rubygems-update --conservative
💎RubyGemsrubygems-update≥ 1.8.24&&< 1.8.271.8.27bundle update rubygems-update --conservative
💎RubyGemsrubygems-update≥ 2.0.0&&< 2.0.102.0.10bundle update rubygems-update --conservative
💎RubyGemsrubygems-update≥ 2.1.0&&< 2.1.52.1.5bundle update rubygems-update --conservative

Affected Products

2 products · 71 configurations
Application
rubyruby-lang
6 versions
1.91.9.11.9.21.9.32.02.0.0
Application
rubygemsrubygems
≤ 1.8.23
41 versions
1.8.01.8.11.8.21.8.31.8.41.8.51.8.61.8.71.8.81.8.91.8.101.8.11

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for rubygems-update, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update rubygems-update to 1.8.23.2 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2013-4363 is resolved across your whole dependency graph.

  3. Workarounds

    Cap what an attacker can consume: apply request size, rate and timeout limits in front of the affected component, and run it with memory and CPU limits so exhaustion degrades one worker rather than the whole service.

Frequently Asked Questions

Algorithmic complexity vulnerability in Gem::Version::ANCHORED_VERSION_PATTERN in lib/rubygems/version.rb in RubyGems before 1.8.23.2, 1.8.24 through 1.8.26, 2.0.x before 2.0.10, and 2.1.x before 2.1.5, as used in Ruby 1.9.0 through 2.0.0p247, allows remote attackers to cause a denial of service (CPU consumption) via a crafted gem version that triggers a large amount of backtracking in a regular expression. NOTE: this issue is due to an incomplete fix for CVE-2013-4287.
O3 Security · Impact-Aware SCA

Is CVE-2013-4363 in your dependencies?

Find it across RubyGems, including transitive dependencies.

CVE-2013-4363: rubygems-update DoS — Fixed in 1.8.23.2