GHSA-qvf5-hvjx-wm27 is a medium-severity (CVSS 6.5) CWE-326 vulnerability in org.apache.tomcat.embed:tomcat-embed-core. 1 public exploit or proof-of-concept reference is indexed, so weaponization risk is real. A fix is available for org.apache.tomcat.embed:tomcat-embed-core — see the affected versions and patch details below.
Exploitation Status
No confirmed exploitation observed yet
- CISA assesses this as automatable — exploitation doesn’t require manual, per-target effort, which raises the odds of mass scanning and opportunistic attacks.
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for GHSA-qvf5-hvjx-wm27.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
org.apache.tomcat.embed:tomcat-embed-core☕org.apache.tomcat:tomcat-coyote☕org.apache.tomcat.embed:tomcat-embed-core☕org.apache.tomcat.embed:tomcat-embed-core☕org.apache.tomcat:tomcat-coyote☕org.apache.tomcat:tomcat-coyoteReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.
Description
Incorrect object re-cycling and re-use vulnerability in Apache Tomcat. Incorrect recycling of the request and response used by HTTP/2 requests could lead to request and/or response mix-up between users.
This issue affects Apache Tomcat: from 11.0.0-M23 through 11.0.0-M26, from 10.1.27 through 10.1.30, from 9.0.92 through 9.0.95.
Users are recommended to upgrade to version 11.0.0, 10.1.31 or 9.0.96, which fixes the issue.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| ☕Maven | org.apache.tomcat.embed:tomcat-embed-core | ≥ 9.0.92&&< 9.0.96 | 9.0.96org.apache.tomcat.embed:tomcat-embed-core:9.0.96 |
| ☕Maven | org.apache.tomcat:tomcat-coyote | ≥ 9.0.92&&< 9.0.96 | 9.0.96org.apache.tomcat:tomcat-coyote:9.0.96 |
| ☕Maven | org.apache.tomcat.embed:tomcat-embed-core | ≥ 10.1.27&&< 10.1.31 | 10.1.31org.apache.tomcat.embed:tomcat-embed-core:10.1.31 |
| ☕Maven | org.apache.tomcat.embed:tomcat-embed-core | ≥ 11.0.0-M23&&< 11.0.0 | 11.0.0org.apache.tomcat.embed:tomcat-embed-core:11.0.0 |
| ☕Maven | org.apache.tomcat:tomcat-coyote | ≥ 10.1.27&&< 10.1.31 | 10.1.31org.apache.tomcat:tomcat-coyote:10.1.31 |
| ☕Maven | org.apache.tomcat:tomcat-coyote | ≥ 11.0.0-M23&&< 11.0.0 | 11.0.0org.apache.tomcat:tomcat-coyote:11.0.0 |
Affected Products
tomcatapacheResearch use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.
Detection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.apache.tomcat.embed:tomcat-embed-core, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update org.apache.tomcat.embed:tomcat-embed-core to 9.0.96 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-qvf5-hvjx-wm27 is resolved across your whole dependency graph.
Workarounds
If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.
Frequently Asked Questions
Is GHSA-qvf5-hvjx-wm27 in your dependencies?
Find it across Maven, including transitive dependencies.