CVE-2026-65637 is a critical-severity (CVSS 9.8) Improper Input Validation vulnerability in org.apache.tomcat:tomcat-coyote. A fix is available for org.apache.tomcat:tomcat-coyote — see the affected versions and patch details below.
Apache Tomcat: HTTP/2 no-authority bypass of strict SNI validation - CVE-2026-32990 fix incomplete
Exploitation Status
No confirmed exploitation observed yet
- CISA assesses this as automatable — exploitation doesn’t require manual, per-target effort, which raises the odds of mass scanning and opportunistic attacks.
- A successful exploit gives an attacker total control of the affected component, not partial access.
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for CVE-2026-65637.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
CVE-2026-65637 by exploitation likelihood (EPSS) against impact (CVSS). Outside the shaded patch-first corner.
Where this sits among everything scored
Of 396,257 CVEs with a current EPSS score, this one falls in the < 10% band (highlighted). Counts from FIRST.org, log-scaled.
Real-World Exposure
org.apache.tomcat:tomcat-coyote☕org.apache.tomcat:tomcat-coyote☕org.apache.tomcat:tomcat-coyote☕org.apache.tomcat.embed:tomcat-embed-core☕org.apache.tomcat.embed:tomcat-embed-core☕org.apache.tomcat.embed:tomcat-embed-coreReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.
Description
Improper Input Validation vulnerability in Apache Tomcat due to incomplete fix for CVE-2026-32990.
This issue affects Apache Tomcat: from 11.0.20 through 11.0.24, from 10.1.53 through 10.1.57, from 9.0.115 through 9.0.120.
Users are recommended to upgrade to version 11.0.25, 10.1.58 or 9.0.121, which fix the issue.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| ☕Maven | org.apache.tomcat:tomcat-coyote | ≥ 11.0.20&&< 11.0.25 | 11.0.25org.apache.tomcat:tomcat-coyote:11.0.25 |
| ☕Maven | org.apache.tomcat:tomcat-coyote | ≥ 10.1.53&&< 10.1.59 | 10.1.59org.apache.tomcat:tomcat-coyote:10.1.59 |
| ☕Maven | org.apache.tomcat:tomcat-coyote | ≥ 9.0.115&&< 9.0.121 | 9.0.121org.apache.tomcat:tomcat-coyote:9.0.121 |
| ☕Maven | org.apache.tomcat.embed:tomcat-embed-core | ≥ 11.0.20&&< 11.0.25 | 11.0.25org.apache.tomcat.embed:tomcat-embed-core:11.0.25 |
| ☕Maven | org.apache.tomcat.embed:tomcat-embed-core | ≥ 10.1.53&&< 10.1.59 | 10.1.59org.apache.tomcat.embed:tomcat-embed-core:10.1.59 |
| ☕Maven | org.apache.tomcat.embed:tomcat-embed-core | ≥ 9.0.115&&< 9.0.121 | 9.0.121org.apache.tomcat.embed:tomcat-embed-core:9.0.121 |
Affected Products
tomcatapacheDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.apache.tomcat:tomcat-coyote, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update org.apache.tomcat:tomcat-coyote to 11.0.25 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2026-65637 is resolved across your whole dependency graph.
Workarounds
If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.
Fixing This On Your OS
If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.
This Moderate flaw in Apache Tomcat allows an HTTP/2 no-authority bypass of strict Server Name Indication (SNI) validation due to improper input handling. This could lead to requests being misrouted to an unintended virtual host, potentially exposing sensitive information or causing service disruption in specific…
Mitigation for this issue is either not available or the currently available options do not meet the Red Hat Product Security criteria comprising ease of use and deployment, applicability to widespread installation base, or stability.Source: Red Hat security advisory for CVE-2026-65637 (CC BY 4.0)
| Product | Fixed in | Advisory |
|---|---|---|
| Red Hat JBoss Web Server 7.0.2 | tomcat | RHSA-2026:76956 |
| Red Hat JBoss Web Server 7.0 on RHEL 10 | jws7-tomcat-0:11.0.21-7.redhat_00006.1.el10jws | RHSA-2026:76952 |
| Red Hat Hardened Images | tomcat11-main-11.0.25-0.1.hum1 | RHSA-2026:56039 |
| Red Hat Hardened Images | tomcat10-main-10.1.59-0.1.hum1 | RHSA-2026:63137 |
Frequently Asked Questions
Is CVE-2026-65637 in your dependencies?
Find it across Maven, including transitive dependencies.