NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
☕
☕ Maven
Not in CISA KEV
HIGH severity

CVE-2026-24880 — tomcat-coyote

HIGHFix: apache/tomcat@1b586d6

CVE-2026-24880 is a high-severity (CVSS 7.5) CWE-444 vulnerability in org.apache.tomcat:tomcat-coyote. A fix is available for org.apache.tomcat:tomcat-coyote — see the affected versions and patch details below.

Apache Tomcat: Request smuggling via invalid chunk extension

Also known asBIT-tomcat-2026-24880GHSA-563x-q5rq-57qp
Published
Updated
Affected
6 pkgs
Patched
6 / 6
Exploits
None indexed
Exploitation data as of Nov 7, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

Exploitation Status

No confirmed exploitation observed yet

  • CISA assesses this as automatable — exploitation doesn’t require manual, per-target effort, which raises the odds of mass scanning and opportunistic attacks.
  • CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.

Exploitation and automatability from CISA’s SSVC triage for CVE-2026-24880.

EPSS Exploitation Probability

via FIRST.org ↗
0.7%probability of exploitation in next 30 days
Lower Risk+0.01%
Lower risk than most CVEs54th percentile — riskier than 54% of all scored CVEsHighest risk
0.00%0.40%0.81%1.21%0.2%0.7%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

6 pkgs affected
☕org.apache.tomcat:tomcat-coyote☕org.apache.tomcat:tomcat-coyote☕org.apache.tomcat:tomcat-coyote☕org.apache.tomcat.embed:tomcat-embed-core☕org.apache.tomcat.embed:tomcat-embed-core☕org.apache.tomcat.embed:tomcat-embed-core

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.

Description

Inconsistent Interpretation of HTTP Requests ('HTTP Request/Response Smuggling') vulnerability in Apache Tomcat via invalid chunk extension.

This issue affects Apache Tomcat: from 11.0.0-M1 through 11.0.18, from 10.1.0-M1 through 10.1.52, from 9.0.0.M1 through 9.0.115, from 8.5.0 through 8.5.100, from 7.0.0 through 7.0.109. Other, unsupported versions may also be affected.

Users are recommended to upgrade to version 11.0.20, 10.1.52 or 9.0.116, which fix the issue.

Affected Packages

6 total 6 fixed
EcosystemPackageVulnerable rangeFix
☕Mavenorg.apache.tomcat:tomcat-coyote≥ 7.0.0&&< 9.0.1169.0.116org.apache.tomcat:tomcat-coyote:9.0.116
☕Mavenorg.apache.tomcat:tomcat-coyote≥ 10.1.0-M1&&< 10.1.5210.1.52org.apache.tomcat:tomcat-coyote:10.1.52
☕Mavenorg.apache.tomcat:tomcat-coyote≥ 11.0.0-M1&&< 11.0.2011.0.20org.apache.tomcat:tomcat-coyote:11.0.20
☕Mavenorg.apache.tomcat.embed:tomcat-embed-core≥ 7.0.0&&< 9.0.1169.0.116org.apache.tomcat.embed:tomcat-embed-core:9.0.116
☕Mavenorg.apache.tomcat.embed:tomcat-embed-core≥ 10.1.0-M1&&< 10.1.5210.1.52org.apache.tomcat.embed:tomcat-embed-core:10.1.52
☕Mavenorg.apache.tomcat.embed:tomcat-embed-core≥ 11.0.0-M1&&< 11.0.2011.0.20org.apache.tomcat.embed:tomcat-embed-core:11.0.20

Affected Products

1 product · 3 configurations
Application
tomcatapache
≥ 11.0.0 && < 11.0.20
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.apache.tomcat:tomcat-coyote, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update org.apache.tomcat:tomcat-coyote to 9.0.116 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2026-24880 is resolved across your whole dependency graph.

  3. Workarounds

    If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.

Fixing This On Your OS

If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.

Red HatLow

This vulnerability has a Low impact. A flaw in Apache Tomcat allows for HTTP Request/Response Smuggling through invalid chunk extensions. This could enable a remote attacker to bypass security controls or poison caches by manipulating HTTP request processing. This affects Red Hat Enterprise Linux and Red Hat JBoss Web…

Workaround published by Red Hat
Mitigation for this issue is either not available or the currently available options do not meet the Red Hat Product Security criteria comprising ease of use and deployment, applicability to widespread installation base, or stability.
Source: Red Hat security advisory for CVE-2026-24880 (CC BY 4.0)
ProductFixed inAdvisory
Red Hat Enterprise Linux 10tomcat9-1:9.0.117-1.el10_2RHSA-2026:25341
Red Hat Enterprise Linux 10.0 Extended Update Supporttomcat9-1:9.0.120-1.el10_0RHSA-2026:67163
Red Hat Enterprise Linux 8tomcat-1:9.0.120-1.el8_10RHSA-2026:68677
Red Hat Enterprise Linux 8.8 Telecommunications Update Servicetomcat-1:9.0.120-1.el8_8RHSA-2026:68680
Red Hat Enterprise Linux 9tomcat-1:9.0.117-1.el9_8RHSA-2026:26323
Red Hat Enterprise Linux 9.2 Update Services for SAP Solutionstomcat-1:9.0.120-1.el9_2RHSA-2026:68678
Red Hat Enterprise Linux 9.4 Update Services for SAP Solutionstomcat-1:9.0.120-1.el9_4RHSA-2026:68679
Red Hat Enterprise Linux 9.6 Extended Update Supporttomcat-1:9.0.120-1.el9_6RHSA-2026:68659

Frequently Asked Questions

Inconsistent Interpretation of HTTP Requests ('HTTP Request/Response Smuggling') vulnerability in Apache Tomcat via invalid chunk extension. This issue affects Apache Tomcat: from 11.0.0-M1 through 11.0.18, from 10.1.0-M1 through 10.1.52, from 9.0.0.M1 through 9.0.115, from 8.5.0 through 8.5.100, from 7.0.0 through 7.0.109. Other, unsupported versions may also be affected. Users are recommended to upgrade to version 11.0.20, 10.1.52 or 9.0.116, which fix the issue.
O3 Security · Impact-Aware SCA

Is CVE-2026-24880 in your dependencies?

Find it across Maven, including transitive dependencies.

CVE-2026-24880: tomcat-coyote — Fixed in 9.0.116