NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
☕
☕ Maven
Not in CISA KEV
MEDIUM severity

CVE-2026-24733 — tomcat-coyote

MEDIUMFix: apache/tomcat@2e2fa23

CVE-2026-24733 is a medium-severity (CVSS 6.5) Improper Input Validation vulnerability in org.apache.tomcat:tomcat-coyote. A fix is available for org.apache.tomcat:tomcat-coyote — see the affected versions and patch details below.

Apache Tomcat: Security constraint bypass with HTTP/0.9

Also known asBIT-tomcat-2026-24733GHSA-qq5r-98hh-rxc9
Published
Updated
Affected
3 pkgs
Patched
3 / 3
Exploits
None indexed
Exploitation data as of Nov 6, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

Exploitation Status

No confirmed exploitation observed yet

  • CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.

Exploitation and automatability from CISA’s SSVC triage for CVE-2026-24733.

EPSS Exploitation Probability

via FIRST.org ↗
0.6%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs46th percentile — riskier than 46% of all scored CVEsHighest risk
0.00%0.35%0.70%1.05%0.2%0.6%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

3 pkgs affected
☕org.apache.tomcat:tomcat-coyote☕org.apache.tomcat:tomcat-coyote☕org.apache.tomcat:tomcat-coyote

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.

Description

Improper Input Validation vulnerability in Apache Tomcat.

Tomcat did not limit HTTP/0.9 requests to the GET method. If a security constraint was configured to allow HEAD requests to a URI but deny GET requests, the user could bypass that constraint on GET requests by sending a (specification invalid) HEAD request using HTTP/0.9.

This issue affects Apache Tomcat: from 11.0.0-M1 through 11.0.14, from 10.1.0-M1 through 10.1.49, from 9.0.0.M1 through 9.0.112.

Older, EOL versions are also affected.

Users are recommended to upgrade to version 11.0.15 or later, 10.1.50 or later or 9.0.113 or later, which fixes the issue.

Affected Packages

3 total 3 fixed
EcosystemPackageVulnerable rangeFix
☕Mavenorg.apache.tomcat:tomcat-coyote≥ 11.0.0-M1&&< 11.0.1511.0.15org.apache.tomcat:tomcat-coyote:11.0.15
☕Mavenorg.apache.tomcat:tomcat-coyote≥ 10.1.0-M1&&< 10.1.5010.1.50org.apache.tomcat:tomcat-coyote:10.1.50
☕Mavenorg.apache.tomcat:tomcat-coyoteall versions9.0.113org.apache.tomcat:tomcat-coyote:9.0.113

Affected Products

1 product · 66 configurations
Application
tomcatapache
≥ 11.0.1 && < 11.0.15
3 versions
9.0.010.0.011.0.0

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.apache.tomcat:tomcat-coyote, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update org.apache.tomcat:tomcat-coyote to 11.0.15 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2026-24733 is resolved across your whole dependency graph.

  3. Workarounds

    If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.

Fixing This On Your OS

If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.

Red HatLow

This flaw is only exploitable when Tomcat is configured to allow HEAD requests but deny GET requests to the same resource, a very unlikely configuration. Due to this reason, this flaw has been rated with a low severity.

Workaround published by Red Hat
To mitigate this vulnerability, ensure that security constraints are consistent across similar methods (e.g., if GET is denied, HEAD should likely be denied) or block HTTP/0.9 traffic via a reverse proxy or firewall, if it is not required.
Source: Red Hat security advisory for CVE-2026-24733 (CC BY 4.0)
ProductFixed inAdvisory
Red Hat Enterprise Linux 10tomcat9-1:9.0.117-1.el10_2RHSA-2026:25341
Red Hat Enterprise Linux 10.0 Extended Update Supporttomcat9-1:9.0.120-1.el10_0RHSA-2026:67163
Red Hat Enterprise Linux 8tomcat-1:9.0.120-1.el8_10RHSA-2026:68677
Red Hat Enterprise Linux 8.8 Telecommunications Update Servicetomcat-1:9.0.120-1.el8_8RHSA-2026:68680
Red Hat Enterprise Linux 9tomcat-1:9.0.117-1.el9_8RHSA-2026:26323
Red Hat Enterprise Linux 9.2 Update Services for SAP Solutionstomcat-1:9.0.120-1.el9_2RHSA-2026:68678
Red Hat Enterprise Linux 9.4 Update Services for SAP Solutionstomcat-1:9.0.120-1.el9_4RHSA-2026:68679
Red Hat Enterprise Linux 9.6 Extended Update Supporttomcat-1:9.0.120-1.el9_6RHSA-2026:68659

Frequently Asked Questions

Improper Input Validation vulnerability in Apache Tomcat. Tomcat did not limit HTTP/0.9 requests to the GET method. If a security constraint was configured to allow HEAD requests to a URI but deny GET requests, the user could bypass that constraint on GET requests by sending a (specification invalid) HEAD request using HTTP/0.9. This issue affects Apache Tomcat: from 11.0.0-M1 through 11.0.14, from 10.1.0-M1 through 10.1.49, from 9.0.0.M1 through 9.0.112. Older, EOL versions are also affected. Users are recommended to upgrade to version 11.0.15 or later, 10.1.50 or later or 9.0.113 o
O3 Security · Impact-Aware SCA

Is CVE-2026-24733 in your dependencies?

Find it across Maven, including transitive dependencies.

CVE-2026-24733: tomcat-coyote — Fixed in 11.0.15