CVE-2026-55957 is a high-severity (CVSS 7.3) CWE-304 vulnerability in org.apache.tomcat.embed:tomcat-embed-core. A fix is available for org.apache.tomcat.embed:tomcat-embed-core — see the affected versions and patch details below.
Apache Tomcat: Authentication bypass with JNDIRealm and GSSAPI authenticated bind
Exploitation Status
No confirmed exploitation observed yet
- CISA assesses this as automatable — exploitation doesn’t require manual, per-target effort, which raises the odds of mass scanning and opportunistic attacks.
- A successful exploit gives an attacker total control of the affected component, not partial access.
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for CVE-2026-55957.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
org.apache.tomcat.embed:tomcat-embed-core☕org.apache.tomcat.embed:tomcat-embed-core☕org.apache.tomcat.embed:tomcat-embed-core☕org.apache.tomcat.embed:tomcat-embed-core☕org.apache.tomcat.embed:tomcat-embed-core☕org.apache.tomcat:tomcat☕org.apache.tomcat:tomcat☕org.apache.tomcat:tomcat+7 moreReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.
Description
Missing Critical Step in Authentication vulnerability in Apache Tomcat when the JNDIRealm was configured to authenticate binds using GSSAPI allowed attackers to authenticate without provided the correct password.
This issue affects Apache Tomcat: from 11.0.0-M1 through 11.0.4, from 10.1.0-M1 through 10.1.36, from 9.0.0.M1 through 9.0.100, from 8.5.0 through 8.5.100, from 7.0.0 through 7.0.109.
Users are recommended to upgrade to version 11.0.5, 10.1.37 or 9.0.101, which fixes the issue.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| ☕Maven | org.apache.tomcat.embed:tomcat-embed-core | ≥ 11.0.0-M1&&< 11.0.5 | 11.0.5org.apache.tomcat.embed:tomcat-embed-core:11.0.5 |
| ☕Maven | org.apache.tomcat.embed:tomcat-embed-core | ≥ 10.1.0-M1&&< 10.1.37 | 10.1.37org.apache.tomcat.embed:tomcat-embed-core:10.1.37 |
| ☕Maven | org.apache.tomcat.embed:tomcat-embed-core | ≥ 9.0.0.M1&&< 9.0.101 | 9.0.101org.apache.tomcat.embed:tomcat-embed-core:9.0.101 |
| ☕Maven | org.apache.tomcat.embed:tomcat-embed-core | ≥ 8.5.0 | No fix |
| ☕Maven | org.apache.tomcat.embed:tomcat-embed-core | all versions | No fix |
| ☕Maven | org.apache.tomcat:tomcat | ≥ 11.0.0-M1&&< 11.0.5 | 11.0.5org.apache.tomcat:tomcat:11.0.5 |
Affected Products
tomcatapacheDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.apache.tomcat.embed:tomcat-embed-core, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update org.apache.tomcat.embed:tomcat-embed-core to 11.0.5 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2026-55957 is resolved across your whole dependency graph.
Workarounds
If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.
Fixing This On Your OS
If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.
This issue is rated as Important severity because it allows an attacker to fully bypass password verification when authenticating against a Tomcat instance, potentially gaining unauthorized access to protected resources without any privileges or user interaction required.
Red Hat has investigated whether a possible mitigation exists for this issue, and has not been able to identify a practical example. Please update the affected package as soon as possible.Source: Red Hat security advisory for CVE-2026-55957 (CC BY 4.0)
| Product | Fixed in | Advisory |
|---|---|---|
| Red Hat Enterprise Linux 10 | tomcat9-1:9.0.110-2.el10_2 | RHSA-2026:18536 |
| Red Hat Enterprise Linux 10 | tomcat-1:10.1.49-1.el10 | RHSA-2026:18537 |
| Red Hat Enterprise Linux 10.0 Extended Update Support | tomcat9-1:9.0.120-1.el10_0 | RHSA-2026:67163 |
| Red Hat Enterprise Linux 10.0 Extended Update Support | tomcat-1:10.1.49-1.el10_0 | RHSA-2026:67164 |
| Red Hat Enterprise Linux 8 | tomcat-1:9.0.120-1.el8_10 | RHSA-2026:68677 |
| Red Hat Enterprise Linux 8.8 Telecommunications Update Service | tomcat-1:9.0.120-1.el8_8 | RHSA-2026:68680 |
| Red Hat Enterprise Linux 9 | tomcat-1:9.0.110-2.el9_8 | RHSA-2026:18916 |
| Red Hat Enterprise Linux 9.2 Update Services for SAP Solutions | tomcat-1:9.0.120-1.el9_2 | RHSA-2026:68678 |
Frequently Asked Questions
Is CVE-2026-55957 in your dependencies?
Find it across Maven, including transitive dependencies.