CVE-2026-53404 is a high-severity (CVSS 7.3) CWE-670 vulnerability in org.apache.tomcat.embed:tomcat-embed-core. A fix is available for org.apache.tomcat.embed:tomcat-embed-core — see the affected versions and patch details below.
Apache Tomcat: Bad ornext processing in RewriteValve
Exploitation Status
No confirmed exploitation observed yet
- CISA assesses this as automatable — exploitation doesn’t require manual, per-target effort, which raises the odds of mass scanning and opportunistic attacks.
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for CVE-2026-53404.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
org.apache.tomcat.embed:tomcat-embed-core☕org.apache.tomcat.embed:tomcat-embed-core☕org.apache.tomcat.embed:tomcat-embed-core☕org.apache.tomcat.embed:tomcat-embed-core☕org.apache.tomcat:tomcat☕org.apache.tomcat:tomcat☕org.apache.tomcat:tomcat☕org.apache.tomcat:tomcat+4 moreReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.
Description
Always-Incorrect Control Flow Implementation vulnerability in Apache Tomcat's rewrite valve meant that if the first condition in an OR chain matched, subsequent non-OR conditions were skipped.
This issue affects Apache Tomcat: from 11.0.0-M1 through 11.0.22, from 10.1.0-M1 through 10.1.55, from 9.0.0.M1 through 9.0.118, from 8.5.0 through 8.5.100. Other versions that have reached end of support may also be affected.
Users are recommended to upgrade to version 11.0.23, 10.1.56 or 9.0.119, which fix the issue.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| ☕Maven | org.apache.tomcat.embed:tomcat-embed-core | ≥ 11.0.0-M1&&< 11.0.23 | 11.0.23org.apache.tomcat.embed:tomcat-embed-core:11.0.23 |
| ☕Maven | org.apache.tomcat.embed:tomcat-embed-core | ≥ 10.1.0-M1&&< 10.1.56 | 10.1.56org.apache.tomcat.embed:tomcat-embed-core:10.1.56 |
| ☕Maven | org.apache.tomcat.embed:tomcat-embed-core | ≥ 9.0.0.M1&&< 9.0.119 | 9.0.119org.apache.tomcat.embed:tomcat-embed-core:9.0.119 |
| ☕Maven | org.apache.tomcat.embed:tomcat-embed-core | ≥ 8.5.0 | No fix |
| ☕Maven | org.apache.tomcat:tomcat | ≥ 11.0.0-M1&&< 11.0.23 | 11.0.23org.apache.tomcat:tomcat:11.0.23 |
| ☕Maven | org.apache.tomcat:tomcat | ≥ 10.1.0-M1&&< 10.1.56 | 10.1.56org.apache.tomcat:tomcat:10.1.56 |
Affected Products
tomcatapacheDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.apache.tomcat.embed:tomcat-embed-core, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update org.apache.tomcat.embed:tomcat-embed-core to 11.0.23 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2026-53404 is resolved across your whole dependency graph.
Workarounds
If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.
Fixing This On Your OS
If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.
A flaw was found in Apache Tomcat's RewriteValve. When rewrite rules use OR-chained conditions followed by non-OR conditions, the processing logic may not evaluate conditions correctly, potentially allowing unintended rule matches. Exploitation requires the RewriteValve to be enabled with specific OR-chained condition…
This vulnerability only affects Tomcat deployments that use the RewriteValve with OR-chained rewrite conditions. Deployments that do not use the RewriteValve are not affected. Review rewrite rules for OR-chained conditions and test rule evaluation behavior.Source: Red Hat security advisory for CVE-2026-53404 (CC BY 4.0)
| Product | Fixed in | Advisory |
|---|---|---|
| Red Hat Enterprise Linux 10 | tomcat9-1:9.0.120-1.el10_2 | RHSA-2026:68651 |
| Red Hat Enterprise Linux 10.0 Extended Update Support | tomcat9-1:9.0.120-1.el10_0 | RHSA-2026:67163 |
| Red Hat Enterprise Linux 8 | tomcat-1:9.0.120-1.el8_10 | RHSA-2026:68677 |
| Red Hat Enterprise Linux 8.8 Telecommunications Update Service | tomcat-1:9.0.120-1.el8_8 | RHSA-2026:68680 |
| Red Hat Enterprise Linux 9 | tomcat-1:9.0.120-2.el9_8 | RHSA-2026:68660 |
| Red Hat Enterprise Linux 9.2 Update Services for SAP Solutions | tomcat-1:9.0.120-1.el9_2 | RHSA-2026:68678 |
| Red Hat Enterprise Linux 9.4 Update Services for SAP Solutions | tomcat-1:9.0.120-1.el9_4 | RHSA-2026:68679 |
| Red Hat Enterprise Linux 9.6 Extended Update Support | tomcat-1:9.0.120-1.el9_6 | RHSA-2026:68659 |
Frequently Asked Questions
Is CVE-2026-53404 in your dependencies?
Find it across Maven, including transitive dependencies.