NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
☕
☕ Maven
Not in CISA KEV
MEDIUM severity

CVE-2024-52317 — tomcat-embed-core

MEDIUMFix: apache/tomcat@146f94f

CVE-2024-52317 is a medium-severity (CVSS 6.5) CWE-326 vulnerability in org.apache.tomcat.embed:tomcat-embed-core. 1 public exploit or proof-of-concept reference is indexed, so weaponization risk is real. A fix is available for org.apache.tomcat.embed:tomcat-embed-core — see the affected versions and patch details below.

Apache Tomcat: Request/response mix-up with HTTP/2

Also known asBIT-tomcat-2024-52317GHSA-qvf5-hvjx-wm27
Published
Updated
Affected
6 pkgs
Patched
6 / 6
Exploits
1 known
Exploitation data as of Oct 30, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

Exploitation Status

No confirmed exploitation observed yet

  • CISA assesses this as automatable — exploitation doesn’t require manual, per-target effort, which raises the odds of mass scanning and opportunistic attacks.
  • CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.

Exploitation and automatability from CISA’s SSVC triage for CVE-2024-52317.

EPSS Exploitation Probability

via FIRST.org ↗
2.1%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs82th percentile — riskier than 82% of all scored CVEsHighest risk
0.00%9.12%18.2%27.3%16.7%2.1%Apr 26Aug 26Oct 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

6 pkgs affected
☕org.apache.tomcat.embed:tomcat-embed-core☕org.apache.tomcat:tomcat-coyote☕org.apache.tomcat.embed:tomcat-embed-core☕org.apache.tomcat.embed:tomcat-embed-core☕org.apache.tomcat:tomcat-coyote☕org.apache.tomcat:tomcat-coyote

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.

Description

Incorrect object re-cycling and re-use vulnerability in Apache Tomcat. Incorrect recycling of the request and response used by HTTP/2 requests could lead to request and/or response mix-up between users.

This issue affects Apache Tomcat: from 11.0.0-M23 through 11.0.0-M26, from 10.1.27 through 10.1.30, from 9.0.92 through 9.0.95.

Users are recommended to upgrade to version 11.0.0, 10.1.31 or 9.0.96, which fixes the issue.

Affected Packages

6 total 6 fixed
EcosystemPackageVulnerable rangeFix
☕Mavenorg.apache.tomcat.embed:tomcat-embed-core≥ 9.0.92&&< 9.0.969.0.96org.apache.tomcat.embed:tomcat-embed-core:9.0.96
☕Mavenorg.apache.tomcat:tomcat-coyote≥ 9.0.92&&< 9.0.969.0.96org.apache.tomcat:tomcat-coyote:9.0.96
☕Mavenorg.apache.tomcat.embed:tomcat-embed-core≥ 10.1.27&&< 10.1.3110.1.31org.apache.tomcat.embed:tomcat-embed-core:10.1.31
☕Mavenorg.apache.tomcat.embed:tomcat-embed-core≥ 11.0.0-M23&&< 11.0.011.0.0org.apache.tomcat.embed:tomcat-embed-core:11.0.0
☕Mavenorg.apache.tomcat:tomcat-coyote≥ 10.1.27&&< 10.1.3110.1.31org.apache.tomcat:tomcat-coyote:10.1.31
☕Mavenorg.apache.tomcat:tomcat-coyote≥ 11.0.0-M23&&< 11.0.011.0.0org.apache.tomcat:tomcat-coyote:11.0.0

Affected Products

1 product · 6 configurations
Application
tomcatapache
≥ 10.1.27 && < 10.1.31
1 version
11.0.0
Exploits & PoCs
1

Research use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.apache.tomcat.embed:tomcat-embed-core, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update org.apache.tomcat.embed:tomcat-embed-core to 9.0.96 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2024-52317 is resolved across your whole dependency graph.

  3. Workarounds

    If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.

Frequently Asked Questions

Incorrect object re-cycling and re-use vulnerability in Apache Tomcat. Incorrect recycling of the request and response used by HTTP/2 requests could lead to request and/or response mix-up between users. This issue affects Apache Tomcat: from 11.0.0-M23 through 11.0.0-M26, from 10.1.27 through 10.1.30, from 9.0.92 through 9.0.95. Users are recommended to upgrade to version 11.0.0, 10.1.31 or 9.0.96, which fixes the issue.
O3 Security · Impact-Aware SCA

Is CVE-2024-52317 in your dependencies?

Find it across Maven, including transitive dependencies.

CVE-2024-52317: tomcat-embed-core — Fixed in 9.0.96