Incorrect Permission Assignment for Critical Resource in Apache hiveGHSA-p639-xxv5-j383
LOWGHSA-p639-xxv5-j383 is a low-severity (CVSS 3.7) CWE-732 vulnerability in org.apache.hive:hive. A fix is available for org.apache.hive:hive — see the affected versions and patch details below.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
org.apache.hive:hive☕org.apache.hive:hive-exec☕org.apache.hive:hive-serviceReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.
Description
In Apache Hive 2.1.0 to 2.3.2, when 'COPY FROM FTP' statement is run using HPL/SQL extension to Hive, a compromised/malicious FTP server can cause the file to be written to an arbitrary location on the cluster where the command is run from. This is because FTP client code in HPL/SQL does not verify the destination location of the downloaded file. This does not affect hive cli user and hiveserver2 user as hplsql is a separate command line script and needs to be invoked differently.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| ☕Maven | org.apache.hive:hive | ≥ 2.1.0&&< 2.3.3 | 2.3.3org.apache.hive:hive:2.3.3 |
| ☕Maven | org.apache.hive:hive-exec | ≥ 2.1.0&&< 2.3.3 | 2.3.3org.apache.hive:hive-exec:2.3.3 |
| ☕Maven | org.apache.hive:hive-service | ≥ 2.1.0&&< 2.3.3 | 2.3.3org.apache.hive:hive-service:2.3.3 |
Affected Products
hiveapacheDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.apache.hive:hive, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update org.apache.hive:hive to 2.3.3 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-p639-xxv5-j383 is resolved across your whole dependency graph.
Workarounds
If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.
Frequently Asked Questions
Is GHSA-p639-xxv5-j383 in your dependencies?
Find it across Maven, including transitive dependencies.