NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
☕
☕ Maven
Not in CISA KEV
LOW severity

CVE-2018-1315 — hive

LOW

CVE-2018-1315 is a low-severity (CVSS 3.7) CWE-732 vulnerability in org.apache.hive:hive. A fix is available for org.apache.hive:hive — see the affected versions and patch details below.

Incorrect Permission Assignment for Critical Resource in Apache hive

Also known asGHSA-p639-xxv5-j383
Published
Updated
Affected
3 pkgs
Patched
3 / 3
Exploits
None indexed
Exploitation data as of Oct 23, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
1.7%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs78th percentile — riskier than 78% of all scored CVEsHighest risk
0.53%1.11%1.70%2.28%1.0%1.7%Apr 26Aug 26Oct 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

3 pkgs affected
☕org.apache.hive:hive☕org.apache.hive:hive-exec☕org.apache.hive:hive-service

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.

Description

In Apache Hive 2.1.0 to 2.3.2, when 'COPY FROM FTP' statement is run using HPL/SQL extension to Hive, a compromised/malicious FTP server can cause the file to be written to an arbitrary location on the cluster where the command is run from. This is because FTP client code in HPL/SQL does not verify the destination location of the downloaded file. This does not affect hive cli user and hiveserver2 user as hplsql is a separate command line script and needs to be invoked differently.

Affected Packages

3 total 3 fixed
EcosystemPackageVulnerable rangeFix
☕Mavenorg.apache.hive:hive≥ 2.1.0&&< 2.3.32.3.3org.apache.hive:hive:2.3.3
☕Mavenorg.apache.hive:hive-exec≥ 2.1.0&&< 2.3.32.3.3org.apache.hive:hive-exec:2.3.3
☕Mavenorg.apache.hive:hive-service≥ 2.1.0&&< 2.3.32.3.3org.apache.hive:hive-service:2.3.3

Affected Products

1 product · 1 configurations
Application
hiveapache
≥ 2.1.0 && ≤ 2.3.2
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.apache.hive:hive, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update org.apache.hive:hive to 2.3.3 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2018-1315 is resolved across your whole dependency graph.

  3. Workarounds

    If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.

Frequently Asked Questions

In Apache Hive 2.1.0 to 2.3.2, when 'COPY FROM FTP' statement is run using HPL/SQL extension to Hive, a compromised/malicious FTP server can cause the file to be written to an arbitrary location on the cluster where the command is run from. This is because FTP client code in HPL/SQL does not verify the destination location of the downloaded file. This does not affect hive cli user and hiveserver2 user as hplsql is a separate command line script and needs to be invoked differently.
O3 Security · Impact-Aware SCA

Is CVE-2018-1315 in your dependencies?

Find it across Maven, including transitive dependencies.

CVE-2018-1315: hive — Fixed in 2.3.3