CVE-2017-12625 — hive
MEDIUMCVE-2017-12625 is a medium-severity (CVSS 4.3) Information Exposure vulnerability in org.apache.hive:hive. A fix is available for org.apache.hive:hive — see the affected versions and patch details below.
Moderate severity vulnerability that affects org.apache.hive:hive, org.apache.hive:hive-exec, and org.apache.hive:hive-service
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
org.apache.hive:hive☕org.apache.hive:hive☕org.apache.hive:hive☕org.apache.hive:hive-exec☕org.apache.hive:hive-exec☕org.apache.hive:hive-exec☕org.apache.hive:hive-service☕org.apache.hive:hive-service+1 moreReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.
Description
Apache Hive 2.1.x before 2.1.2, 2.2.x before 2.2.1, and 2.3.x before 2.3.1 expose an interface through which masking policies can be defined on tables or views, e.g., using Apache Ranger. When a view is created over a given table, the policy enforcement does not happen correctly on the table for masked columns.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| ☕Maven | org.apache.hive:hive | ≥ 2.1.0&&< 2.1.2 | 2.1.2org.apache.hive:hive:2.1.2 |
| ☕Maven | org.apache.hive:hive | ≥ 2.2.0&&< 2.2.1 | 2.2.1org.apache.hive:hive:2.2.1 |
| ☕Maven | org.apache.hive:hive | ≥ 2.3.0&&< 2.3.1 | 2.3.1org.apache.hive:hive:2.3.1 |
| ☕Maven | org.apache.hive:hive-exec | ≥ 2.1.0&&< 2.1.2 | 2.1.2org.apache.hive:hive-exec:2.1.2 |
| ☕Maven | org.apache.hive:hive-exec | ≥ 2.2.0&&< 2.2.1 | 2.2.1org.apache.hive:hive-exec:2.2.1 |
| ☕Maven | org.apache.hive:hive-exec | ≥ 2.3.0&&< 2.3.1 | 2.3.1org.apache.hive:hive-exec:2.3.1 |
Affected Products
hiveapacheDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.apache.hive:hive, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update org.apache.hive:hive to 2.1.2 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2017-12625 is resolved across your whole dependency graph.
Workarounds
Assume what was exposed is already known: rotate any credential, token or key that the affected component could return, restrict the endpoint to callers that genuinely need it, and strip sensitive fields from responses and error output at the boundary rather than relying on the client not to read them.
Frequently Asked Questions
Is CVE-2017-12625 in your dependencies?
Find it across Maven, including transitive dependencies.