NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
☕
☕ Maven
Not in CISA KEV
MEDIUM severity

Moderate severity vulnerability that affects org.apache.hive:hive, org.apache.hive:hive-exec, and org.apache.hive:hive-serviceGHSA-2g9q-chq2-w8qw

MEDIUM

GHSA-2g9q-chq2-w8qw is a medium-severity (CVSS 4.3) Information Exposure vulnerability in org.apache.hive:hive. A fix is available for org.apache.hive:hive — see the affected versions and patch details below.

Also known asCVE-2017-12625
Published
Updated
Affected
9 pkgs
Patched
9 / 9
Exploits
None indexed
Exploitation data as of Oct 31, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
1.4%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs73th percentile — riskier than 73% of all scored CVEsHighest risk
0.00%0.64%1.29%1.93%0.5%1.4%May 26Sep 26Oct 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

9 pkgs affected
☕org.apache.hive:hive☕org.apache.hive:hive☕org.apache.hive:hive☕org.apache.hive:hive-exec☕org.apache.hive:hive-exec☕org.apache.hive:hive-exec☕org.apache.hive:hive-service☕org.apache.hive:hive-service+1 more

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.

Description

Apache Hive 2.1.x before 2.1.2, 2.2.x before 2.2.1, and 2.3.x before 2.3.1 expose an interface through which masking policies can be defined on tables or views, e.g., using Apache Ranger. When a view is created over a given table, the policy enforcement does not happen correctly on the table for masked columns.

Affected Packages

9 total 9 fixed
EcosystemPackageVulnerable rangeFix
☕Mavenorg.apache.hive:hive≥ 2.1.0&&< 2.1.22.1.2org.apache.hive:hive:2.1.2
☕Mavenorg.apache.hive:hive≥ 2.2.0&&< 2.2.12.2.1org.apache.hive:hive:2.2.1
☕Mavenorg.apache.hive:hive≥ 2.3.0&&< 2.3.12.3.1org.apache.hive:hive:2.3.1
☕Mavenorg.apache.hive:hive-exec≥ 2.1.0&&< 2.1.22.1.2org.apache.hive:hive-exec:2.1.2
☕Mavenorg.apache.hive:hive-exec≥ 2.2.0&&< 2.2.12.2.1org.apache.hive:hive-exec:2.2.1
☕Mavenorg.apache.hive:hive-exec≥ 2.3.0&&< 2.3.12.3.1org.apache.hive:hive-exec:2.3.1

Affected Products

1 product · 4 configurations
Application
hiveapache
4 versions
2.1.02.1.12.2.02.3.0

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.apache.hive:hive, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update org.apache.hive:hive to 2.1.2 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-2g9q-chq2-w8qw is resolved across your whole dependency graph.

  3. Workarounds

    Assume what was exposed is already known: rotate any credential, token or key that the affected component could return, restrict the endpoint to callers that genuinely need it, and strip sensitive fields from responses and error output at the boundary rather than relying on the client not to read them.

Frequently Asked Questions

Apache Hive 2.1.x before 2.1.2, 2.2.x before 2.2.1, and 2.3.x before 2.3.1 expose an interface through which masking policies can be defined on tables or views, e.g., using Apache Ranger. When a view is created over a given table, the policy enforcement does not happen correctly on the table for masked columns.
O3 Security · Impact-Aware SCA

Is GHSA-2g9q-chq2-w8qw in your dependencies?

Find it across Maven, including transitive dependencies.

Moderate severity vulnerability that affects…