CVE-2015-1772 — hive
HIGHCVE-2015-1772 is a high-severity (CVSS 7.3) Improper Authentication vulnerability in org.apache.hive:hive. A fix is available for org.apache.hive:hive — see the affected versions and patch details below.
Improper Authentication in org.apache.hive:hive, org.apache.hive:hive-exec, and org.apache.hive:hive-service
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
org.apache.hive:hive☕org.apache.hive:hive☕org.apache.hive:hive-exec☕org.apache.hive:hive-exec☕org.apache.hive:hive-service☕org.apache.hive:hive-serviceReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.
Description
The LDAP implementation in HiveServer2 in Apache Hive before 1.0.1 and 1.1.x before 1.1.1, as used in IBM InfoSphere BigInsights 3.0, 3.0.0.1, and 3.0.0.2 and other products, mishandles simple unauthenticated and anonymous bind configurations, which allows remote attackers to bypass authentication via a crafted LDAP request.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| ☕Maven | org.apache.hive:hive | ≥ 1.0.0&&< 1.0.1 | 1.0.1org.apache.hive:hive:1.0.1 |
| ☕Maven | org.apache.hive:hive | ≥ 1.1.0&&< 1.1.1 | 1.1.1org.apache.hive:hive:1.1.1 |
| ☕Maven | org.apache.hive:hive-exec | ≥ 1.0.0&&< 1.0.1 | 1.0.1org.apache.hive:hive-exec:1.0.1 |
| ☕Maven | org.apache.hive:hive-exec | ≥ 1.1.0&&< 1.1.1 | 1.1.1org.apache.hive:hive-exec:1.1.1 |
| ☕Maven | org.apache.hive:hive-service | ≥ 1.0.0&&< 1.0.1 | 1.0.1org.apache.hive:hive-service:1.0.1 |
| ☕Maven | org.apache.hive:hive-service | ≥ 1.1.0&&< 1.1.1 | 1.1.1org.apache.hive:hive-service:1.1.1 |
Affected Products
hiveapacheinfosphere biginsightsibmDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.apache.hive:hive, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update org.apache.hive:hive to 1.0.1 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2015-1772 is resolved across your whole dependency graph.
Workarounds
Put an independent control in front of the weakness: restrict the affected endpoint or interface to trusted networks, require an additional authentication factor or proxy-level check, and invalidate existing sessions and credentials in case the flaw has already been used.
Frequently Asked Questions
Is CVE-2015-1772 in your dependencies?
Find it across Maven, including transitive dependencies.