CVE-2016-3083 — hive
HIGHCVE-2016-3083 is a high-severity (CVSS 7.5) CWE-295 vulnerability in org.apache.hive:hive. A fix is available for org.apache.hive:hive — see the affected versions and patch details below.
org.apache.hive:hive, org.apache.hive:hive-exec, and org.apache.hive:hive-service vulnerable to Improper Certificate Validation
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
org.apache.hive:hive☕org.apache.hive:hive☕org.apache.hive:hive-service☕org.apache.hive:hive-service☕org.apache.hive:hive-exec☕org.apache.hive:hive-execReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.
Description
Apache Hive (JDBC + HiveServer2) implements SSL for plain TCP and HTTP connections (it supports both transport modes). While validating the server's certificate during the connection setup, the client in Apache Hive before 1.2.2 and 2.0.x before 2.0.1 doesn't seem to be verifying the common name attribute of the certificate. In this way, if a JDBC client sends an SSL request to server abc.com, and the server responds with a valid certificate (certified by CA) but issued to xyz.com, the client will accept that as a valid certificate and the SSL handshake will go through.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| ☕Maven | org.apache.hive:hive | all versions | 1.2.2org.apache.hive:hive:1.2.2 |
| ☕Maven | org.apache.hive:hive | ≥ 2.0.0&&< 2.0.1 | 2.0.1org.apache.hive:hive:2.0.1 |
| ☕Maven | org.apache.hive:hive-service | all versions | 1.2.2org.apache.hive:hive-service:1.2.2 |
| ☕Maven | org.apache.hive:hive-service | ≥ 2.0.0&&< 2.0.1 | 2.0.1org.apache.hive:hive-service:2.0.1 |
| ☕Maven | org.apache.hive:hive-exec | all versions | 1.2.2org.apache.hive:hive-exec:1.2.2 |
| ☕Maven | org.apache.hive:hive-exec | ≥ 2.0.0&&< 2.0.1 | 2.0.1org.apache.hive:hive-exec:2.0.1 |
Affected Products
hiveapacheDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.apache.hive:hive, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update org.apache.hive:hive to 1.2.2 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2016-3083 is resolved across your whole dependency graph.
Workarounds
If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.
Frequently Asked Questions
Is CVE-2016-3083 in your dependencies?
Find it across Maven, including transitive dependencies.