NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
☕
☕ Maven
Not in CISA KEV
HIGH severity

Stack Overflow in Apache MesosGHSA-p2xq-vcm7-xjj6

HIGH

GHSA-p2xq-vcm7-xjj6 is a high-severity (CVSS 7.5) Buffer Overflow vulnerability in org.apache.mesos:mesos. A fix is available for org.apache.mesos:mesos — see the affected versions and patch details below.

Also known asCVE-2018-11793
Published
Updated
Affected
4 pkgs
Patched
4 / 4
Exploits
None indexed
Exploitation data as of Oct 28, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
5.0%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs92th percentile — riskier than 92% of all scored CVEsHighest risk
4.11%5.46%6.82%8.17%7.4%5.0%Apr 26Aug 26Oct 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

4 pkgs affected
☕org.apache.mesos:mesos☕org.apache.mesos:mesos☕org.apache.mesos:mesos☕org.apache.mesos:mesos

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.

Description

When parsing a JSON payload with deeply nested JSON structures, the parser in Apache Mesos versions pre-1.4.x, 1.4.0 to 1.4.2, 1.5.0 to 1.5.1, 1.6.0 to 1.6.1, and 1.7.0 might overflow the stack due to unbounded recursion. A malicious actor can therefore cause a denial of service of Mesos masters rendering the Mesos-controlled cluster inoperable.

Affected Packages

4 total 4 fixed
EcosystemPackageVulnerable rangeFix
☕Mavenorg.apache.mesos:mesosall versions1.4.3org.apache.mesos:mesos:1.4.3
☕Mavenorg.apache.mesos:mesos≥ 1.5.0&&< 1.5.21.5.2org.apache.mesos:mesos:1.5.2
☕Mavenorg.apache.mesos:mesos≥ 1.6.0&&< 1.6.21.6.2org.apache.mesos:mesos:1.6.2
☕Mavenorg.apache.mesos:mesos≥ 1.7.0&&< 1.7.11.7.1org.apache.mesos:mesos:1.7.1

Affected Products

1 product · 10 configurations
Application
mesosapache
≥ 1.7.0 && < 1.7.1
2 versions
1.4.01.8.0

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.apache.mesos:mesos, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update org.apache.mesos:mesos to 1.4.3 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-p2xq-vcm7-xjj6 is resolved across your whole dependency graph.

  3. Workarounds

    Stop feeding it untrusted input: reject or quarantine files and payloads from unverified sources until you can upgrade, restrict accepted formats to the ones you actually need, and run the parsing or decoding step in a least-privileged sandbox or short-lived worker so a crash or corrupted read cannot reach the rest of the process.

Frequently Asked Questions

When parsing a JSON payload with deeply nested JSON structures, the parser in Apache Mesos versions pre-1.4.x, 1.4.0 to 1.4.2, 1.5.0 to 1.5.1, 1.6.0 to 1.6.1, and 1.7.0 might overflow the stack due to unbounded recursion. A malicious actor can therefore cause a denial of service of Mesos masters rendering the Mesos-controlled cluster inoperable.
O3 Security · Impact-Aware SCA

Is GHSA-p2xq-vcm7-xjj6 in your dependencies?

Find it across Maven, including transitive dependencies.

Stack Overflow in Apache Mesos (High 7.5)