CVE-2017-7687 — mesos
HIGHCVE-2017-7687 is a high-severity (CVSS 7.5) vulnerability in org.apache.mesos:mesos. A fix is available for org.apache.mesos:mesos — see the affected versions and patch details below.
Denial of service in Apache Mesos
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
org.apache.mesos:mesos☕org.apache.mesos:mesos☕org.apache.mesos:mesosReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.
Description
When handling a decoding failure for a malformed URL path of an HTTP request, libprocess in Apache Mesos before 1.1.3, 1.2.x before 1.2.2, 1.3.x before 1.3.1, and 1.4.0-dev might crash because the code accidentally calls inappropriate function. A malicious actor can therefore cause a denial of service of Mesos masters rendering the Mesos-controlled cluster inoperable.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| ☕Maven | org.apache.mesos:mesos | all versions | 1.1.3org.apache.mesos:mesos:1.1.3 |
| ☕Maven | org.apache.mesos:mesos | ≥ 1.2.0&&< 1.2.2 | 1.2.2org.apache.mesos:mesos:1.2.2 |
| ☕Maven | org.apache.mesos:mesos | ≥ 1.3.0&&< 1.3.1 | 1.3.1org.apache.mesos:mesos:1.3.1 |
Affected Products
mesosapacheDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.apache.mesos:mesos, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update org.apache.mesos:mesos to 1.1.3 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2017-7687 is resolved across your whole dependency graph.
Workarounds
Cap what an attacker can consume: apply request size, rate and timeout limits in front of the affected component, and run it with memory and CPU limits so exhaustion degrades one worker rather than the whole service.
Frequently Asked Questions
Is CVE-2017-7687 in your dependencies?
Find it across Maven, including transitive dependencies.