CVE-2017-9790 — mesos
HIGHCVE-2017-9790 is a high-severity (CVSS 7.5) Use After Free vulnerability in org.apache.mesos:mesos. A fix is available for org.apache.mesos:mesos — see the affected versions and patch details below.
Use after free in Apache Mesos
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
org.apache.mesos:mesos☕org.apache.mesos:mesos☕org.apache.mesos:mesosReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.
Description
When handling a libprocess message wrapped in an HTTP request, libprocess in Apache Mesos before 1.1.3, 1.2.x before 1.2.2, 1.3.x before 1.3.1, and 1.4.0-dev crashes if the request path is empty, because the parser assumes the request path always starts with '/'. A malicious actor can therefore cause a denial of service of Mesos masters rendering the Mesos-controlled cluster inoperable.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| ☕Maven | org.apache.mesos:mesos | all versions | 1.1.3org.apache.mesos:mesos:1.1.3 |
| ☕Maven | org.apache.mesos:mesos | ≥ 1.2.0&&< 1.2.2 | 1.2.2org.apache.mesos:mesos:1.2.2 |
| ☕Maven | org.apache.mesos:mesos | ≥ 1.3.0&&< 1.3.1 | 1.3.1org.apache.mesos:mesos:1.3.1 |
Affected Products
mesosapacheDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.apache.mesos:mesos, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update org.apache.mesos:mesos to 1.1.3 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2017-9790 is resolved across your whole dependency graph.
Workarounds
Stop feeding it untrusted input: reject or quarantine files and payloads from unverified sources until you can upgrade, restrict accepted formats to the ones you actually need, and run the parsing or decoding step in a least-privileged sandbox or short-lived worker so a crash or corrupted read cannot reach the rest of the process.
Frequently Asked Questions
Is CVE-2017-9790 in your dependencies?
Find it across Maven, including transitive dependencies.