NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
☕
☕ Maven
Not in CISA KEV
HIGH severity

CVE-2019-0204 — mesos

HIGH

CVE-2019-0204 is a high-severity (CVSS 7.8) remote code execution vulnerability in org.apache.mesos:mesos. A fix is available for org.apache.mesos:mesos — see the affected versions and patch details below.

Docker image code execution with Apache Mesos

Also known asGHSA-32w9-2qpc-5f9v
Published
Updated
Affected
4 pkgs
Patched
4 / 4
Exploits
None indexed
Exploitation data as of Oct 31, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
2.7%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs86th percentile — riskier than 86% of all scored CVEsHighest risk
0.00%1.16%2.32%3.47%0.2%2.7%Apr 26Aug 26Oct 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

4 pkgs affected
☕org.apache.mesos:mesos☕org.apache.mesos:mesos☕org.apache.mesos:mesos☕org.apache.mesos:mesos

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.

Description

A specifically crafted Docker image running under the root user can overwrite the init helper binary of the container runtime and/or the command executor in Apache Mesos versions pre-1.4.x, 1.4.0 to 1.4.2, 1.5.0 to 1.5.2, 1.6.0 to 1.6.1, and 1.7.0 to 1.7.1. A malicious actor can therefore gain root-level code execution on the host.

Affected Packages

4 total 4 fixed
EcosystemPackageVulnerable rangeFix
☕Mavenorg.apache.mesos:mesosall versions1.4.3org.apache.mesos:mesos:1.4.3
☕Mavenorg.apache.mesos:mesos≥ 1.5.0&&< 1.5.31.5.3org.apache.mesos:mesos:1.5.3
☕Mavenorg.apache.mesos:mesos≥ 1.6.0&&< 1.6.21.6.2org.apache.mesos:mesos:1.6.2
☕Mavenorg.apache.mesos:mesos≥ 1.7.0&&< 1.7.21.7.2org.apache.mesos:mesos:1.7.2

Affected Products

2 products · 6 configurations
Application
mesosapache
≥ 1.7.0 && < 1.7.2
1 version
1.8.0
Application
fuseredhat
1 version
7.5.0

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.apache.mesos:mesos, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update org.apache.mesos:mesos to 1.4.3 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2019-0204 is resolved across your whole dependency graph.

  3. Workarounds

    If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.

Fixing This On Your OS

If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.

Red HatImportant
ProductFixed inAdvisory
Red Hat Fuse 7.5.0mesosRHSA-2019:3892

Frequently Asked Questions

A specifically crafted Docker image running under the root user can overwrite the init helper binary of the container runtime and/or the command executor in Apache Mesos versions pre-1.4.x, 1.4.0 to 1.4.2, 1.5.0 to 1.5.2, 1.6.0 to 1.6.1, and 1.7.0 to 1.7.1. A malicious actor can therefore gain root-level code execution on the host.
O3 Security · Impact-Aware SCA

Is CVE-2019-0204 in your dependencies?

Find it across Maven, including transitive dependencies.

CVE-2019-0204: mesos — Fixed in 1.4.3