October Rain has Stored XSS via SVG Filter BypassGHSA-gcqv-f29m-67gr
MEDIUMGHSA-gcqv-f29m-67gr is a medium-severity (CVSS 4.8) Cross-site Scripting (XSS) vulnerability in october/rain. A fix is available for october/rain — see the affected versions and patch details below.
Exploitation Status
No confirmed exploitation observed yet
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for GHSA-gcqv-f29m-67gr.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
october/rain🐘october/rainReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.
Description
A stored cross-site scripting (XSS) vulnerability was identified in the SVG sanitization logic. The regex pattern used to strip on* event handler attributes could be bypassed using a crafted payload that exploits how the pattern matches attribute boundaries.
Impact
- Stored XSS via malicious SVG files uploaded through the Media Manager
- Could allow privilege escalation if a superuser views or embeds the malicious SVG
- Requires authenticated backend access with media upload permissions (
media.library.create) - SVG must be viewed or embedded in a page to trigger
Patches
The vulnerability has been patched in v3.7.14 and v4.1.10. All users are encouraged to upgrade to the latest patched version.
Workarounds
If upgrading immediately is not possible:
- Disable SVG uploads by adding
svgto the blocked extensions in media configuration - Set
media.clean_vectorstotruein configuration (enabled by default)
References
- Reported by Pentest-Tools.com
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐘Packagist | october/rain | ≥ 4.0.0&&< 4.1.10 | 4.1.10composer require october/rain:^4.1.10 |
| 🐘Packagist | october/rain | all versions | 3.7.14composer require october/rain:^3.7.14 |
Affected Products
octoberoctobercmsDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for october/rain, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update october/rain to 4.1.10 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-gcqv-f29m-67gr is resolved across your whole dependency graph.
Workarounds
Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.
Frequently Asked Questions
Is GHSA-gcqv-f29m-67gr in your dependencies?
Find it across Packagist, including transitive dependencies.