CVE-2017-15284 is a medium-severity (CVSS 5.4) Cross-site Scripting (XSS) vulnerability in october/rain. 3 public exploit or proof-of-concept references are indexed, so weaponization risk is real. A fix is available for october/rain — see the affected versions and patch details below.
OctoberCMS Cross-Site Scripting
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
october/rainReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.
Description
Cross-Site Scripting exists in OctoberCMS 1.0.425 (aka Build 425), allowing a least privileged user to upload an SVG file containing malicious code as the Avatar for the profile. When this is opened by the Admin, it causes JavaScript execution in the context of the Admin account.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐘Packagist | october/rain | all versions | 1.0.426composer require october/rain:^1.0.426 |
Affected Products
octoberoctobercmsResearch use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.
OctoberCMS 1.0.425 (Build 425) - Cross-Site Scripting
by Ishaq Mohammed · Oct 12, 2017
Detection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for october/rain, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update october/rain to 1.0.426 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2017-15284 is resolved across your whole dependency graph.
Workarounds
Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.
Frequently Asked Questions
Is CVE-2017-15284 in your dependencies?
Find it across Packagist, including transitive dependencies.