NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐘
🐘 Packagist
Not in CISA KEV
MEDIUM severity

CVE-2026-22692 — rain

MEDIUM

CVE-2026-22692 is a medium-severity (CVSS 4.9) CWE-284 vulnerability in october/rain. A fix is available for october/rain — see the affected versions and patch details below.

October CMS: Twig Sandbox Bypass via Collection Methods

Also known asGHSA-m5qg-jc75-4jp6
Published
Updated
Affected
2 pkgs
Patched
2 / 2
Exploits
None indexed
Exploitation data as of Nov 4, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

Exploitation Status

No confirmed exploitation observed yet

  • CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.

Exploitation and automatability from CISA’s SSVC triage for CVE-2026-22692.

EPSS Exploitation Probability

via FIRST.org ↗
0.4%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs34th percentile — riskier than 34% of all scored CVEsHighest risk
0.00%0.30%0.60%0.90%0.0%0.4%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

2 pkgs affected
🐘october/rain🐘october/rain

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.

Description

A sandbox bypass vulnerability was identified in the optional Twig safe mode feature (CMS_SAFE_MODE). Certain methods on the collect() helper were not properly restricted, allowing authenticated users with template editing permissions to bypass sandbox protections.

Impact

  • Bypass of Twig sandbox restrictions
  • Only affects installations with CMS_SAFE_MODE enabled (disabled by default)
  • Requires authenticated backend access with CMS template editing permissions

Patches

The vulnerability has been patched in v4.1.5 and v3.7.13. All users who have enabled safe mode are encouraged to upgrade to the latest patched version.

Workarounds

If upgrading immediately is not possible:

  • Disable CMS_SAFE_MODE if untrusted template editing is not required
  • Restrict CMS template editing permissions to fully trusted administrators only

References

  • Reported by Łukasz Rybak

Affected Packages

2 total 2 fixed
EcosystemPackageVulnerable rangeFix
🐘Packagistoctober/rain≥ 4.0.0&&< 4.1.54.1.5composer require october/rain:^4.1.5
🐘Packagistoctober/rainall versions3.7.13composer require october/rain:^3.7.13

Affected Products

1 product · 2 configurations
Application
octoberoctobercms
≥ 4.0.0 && < 4.1.5
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for october/rain, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update october/rain to 4.1.5 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2026-22692 is resolved across your whole dependency graph.

  3. Workarounds

    Put an independent control in front of the weakness: restrict the affected endpoint or interface to trusted networks, require an additional authentication factor or proxy-level check, and invalidate existing sessions and credentials in case the flaw has already been used.

Frequently Asked Questions

A sandbox bypass vulnerability was identified in the optional Twig safe mode feature (`CMS_SAFE_MODE`). Certain methods on the `collect()` helper were not properly restricted, allowing authenticated users with template editing permissions to bypass sandbox protections. ### Impact - Bypass of Twig sandbox restrictions - Only affects installations with `CMS_SAFE_MODE` enabled (disabled by default) - Requires authenticated backend access with CMS template editing permissions ### Patches The vulnerability has been patched in v4.1.5 and v3.7.13. All users who have enabled safe mode are encouraged
O3 Security · Impact-Aware SCA

Is CVE-2026-22692 in your dependencies?

Find it across Packagist, including transitive dependencies.

CVE-2026-22692: rain — Fixed in 4.1.5