October Rain has a Twig Sandbox Bypass via Collection MethodsGHSA-m5qg-jc75-4jp6
MEDIUMGHSA-m5qg-jc75-4jp6 is a medium-severity (CVSS 4.9) CWE-284 vulnerability in october/rain. A fix is available for october/rain — see the affected versions and patch details below.
Exploitation Status
No confirmed exploitation observed yet
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for GHSA-m5qg-jc75-4jp6.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
october/rain🐘october/rainReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.
Description
A sandbox bypass vulnerability was identified in the optional Twig safe mode feature (CMS_SAFE_MODE). Certain methods on the collect() helper were not properly restricted, allowing authenticated users with template editing permissions to bypass sandbox protections.
Impact
- Bypass of Twig sandbox restrictions
- Only affects installations with
CMS_SAFE_MODEenabled (disabled by default) - Requires authenticated backend access with CMS template editing permissions
Patches
The vulnerability has been patched in v4.1.5 and v3.7.13. All users who have enabled safe mode are encouraged to upgrade to the latest patched version.
Workarounds
If upgrading immediately is not possible:
- Disable
CMS_SAFE_MODEif untrusted template editing is not required - Restrict CMS template editing permissions to fully trusted administrators only
References
- Reported by Łukasz Rybak
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐘Packagist | october/rain | ≥ 4.0.0&&< 4.1.5 | 4.1.5composer require october/rain:^4.1.5 |
| 🐘Packagist | october/rain | all versions | 3.7.13composer require october/rain:^3.7.13 |
Affected Products
octoberoctobercmsDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for october/rain, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update october/rain to 4.1.5 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-m5qg-jc75-4jp6 is resolved across your whole dependency graph.
Workarounds
Put an independent control in front of the weakness: restrict the affected endpoint or interface to trusted networks, require an additional authentication factor or proxy-level check, and invalidate existing sessions and credentials in case the flaw has already been used.
Frequently Asked Questions
Is GHSA-m5qg-jc75-4jp6 in your dependencies?
Find it across Packagist, including transitive dependencies.