NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐘 Packagist
Not in CISA KEV

CVE-2026-25133 — rain

CVE-2026-25133 is a Cross-site Scripting (XSS) vulnerability in october/rain. A fix is available for october/rain — see the affected versions and patch details below.

October CMS has Stored XSS via SVG Filter Bypass

Also known asGHSA-gcqv-f29m-67gr
Published
Updated
Affected
2 pkgs
Patched
2 / 2
Exploits
None indexed
Exploitation data as of Nov 5, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

Exploitation Status

No confirmed exploitation observed yet

  • CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.

Exploitation and automatability from CISA’s SSVC triage for CVE-2026-25133.

EPSS Exploitation Probability

via FIRST.org ↗
0.2%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs12th percentile — riskier than 12% of all scored CVEsHighest risk
0.00%0.24%0.48%0.72%0.0%0.2%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

Real-World Exposure

2 pkgs affected
🐘october/rain🐘october/rain

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.

Description

A stored cross-site scripting (XSS) vulnerability was identified in the SVG sanitization logic. The regex pattern used to strip on* event handler attributes could be bypassed using a crafted payload that exploits how the pattern matches attribute boundaries.

Impact

  • Stored XSS via malicious SVG files uploaded through the Media Manager
  • Could allow privilege escalation if a superuser views or embeds the malicious SVG
  • Requires authenticated backend access with media upload permissions (media.library.create)
  • SVG must be viewed or embedded in a page to trigger

Patches

The vulnerability has been patched in v3.7.14 and v4.1.10. All users are encouraged to upgrade to the latest patched version.

Workarounds

If upgrading immediately is not possible:

  • Disable SVG uploads by adding svg to the blocked extensions in media configuration
  • Set media.clean_vectors to true in configuration (enabled by default)

References

  • Reported by Pentest-Tools.com

Affected Packages

2 total 2 fixed
EcosystemPackageVulnerable rangeFix
🐘Packagistoctober/rain≥ 4.0.0&&< 4.1.104.1.10composer require october/rain:^4.1.10
🐘Packagistoctober/rainall versions3.7.14composer require october/rain:^3.7.14

Affected Products

1 product · 2 configurations
Application
octoberoctobercms
≥ 4.0.0 && ≤ 4.1.9
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for october/rain, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update october/rain to 4.1.10 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2026-25133 is resolved across your whole dependency graph.

  3. Workarounds

    Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.

Frequently Asked Questions

A stored cross-site scripting (XSS) vulnerability was identified in the SVG sanitization logic. The regex pattern used to strip `on*` event handler attributes could be bypassed using a crafted payload that exploits how the pattern matches attribute boundaries. ### Impact - Stored XSS via malicious SVG files uploaded through the Media Manager - Could allow privilege escalation if a superuser views or embeds the malicious SVG - Requires authenticated backend access with media upload permissions (`media.library.create`) - SVG must be viewed or embedded in a page to trigger ### Patches The vulne
O3 Security · Impact-Aware SCA

Is CVE-2026-25133 in your dependencies?

Find it across Packagist, including transitive dependencies.

CVE-2026-25133: rain XSS — Fixed in 4.1.10