MoinMoin Cross-site Scripting (XSS) vulnerabilityGHSA-fc72-v54c-x9jg
MEDIUMGHSA-fc72-v54c-x9jg is a medium-severity (CVSS 5.4) Cross-site Scripting (XSS) vulnerability in moin. 3 public exploit or proof-of-concept references are indexed, so weaponization risk is real. A fix is available for moin — see the affected versions and patch details below.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
moin🐍moinReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects PyPI packages — download data is not available via public APIs for these ecosystems.
Description
Cross-site scripting (XSS) vulnerability in action/Despam.py in the Despam action module in MoinMoin 1.8.7 and 1.9.2 allows remote authenticated users to inject arbitrary web script or HTML by creating a page with a crafted URI.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐍PyPI | moin | ≥ 1.9.0&&< 1.9.3 | 1.9.3pip install --upgrade 'moin==1.9.3' |
| 🐍PyPI | moin | ≥ 1.8.0&&< 1.8.8 | 1.8.8pip install --upgrade 'moin==1.8.8' |
Affected Products
moinmoinmoinmoResearch use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.
Detection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for moin, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update moin to 1.9.3 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-fc72-v54c-x9jg is resolved across your whole dependency graph.
Workarounds
Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.
Frequently Asked Questions
Is GHSA-fc72-v54c-x9jg in your dependencies?
Find it across PyPI, including transitive dependencies.