CVE-2010-2969 — moin
MEDIUMCVE-2010-2969 is a medium-severity (CVSS 6.1) Cross-site Scripting (XSS) vulnerability in moin. A fix is available for moin — see the affected versions and patch details below.
MoinMoin cross-site scripting (XSS) vulnerability
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
moin🐍moinReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects PyPI packages — download data is not available via public APIs for these ecosystems.
Description
Multiple cross-site scripting (XSS) vulnerabilities in MoinMoin 1.7.3 and earlier, and 1.9.x before 1.9.3, allow remote attackers to inject arbitrary web script or HTML via crafted content, related to (1) action/LikePages.py, (2) action/chart.py, and (3) action/userprofile.py, a similar issue to CVE-2010-2487.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐍PyPI | moin | all versions | No fix |
| 🐍PyPI | moin | ≥ 1.9.0&&< 1.9.3 | 1.9.3pip install --upgrade 'moin==1.9.3' |
Affected Products
moinmoinmoinmoDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for moin, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
A fix is available for CVE-2010-2969; check the affected-versions list above or the advisory for the patched release of moin, then make sure no transitive dependency still pins the vulnerable range.
Workarounds
Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.
Frequently Asked Questions
Is CVE-2010-2969 in your dependencies?
Find it across PyPI, including transitive dependencies.