CVE-2012-4404 is a medium-severity (CVSS 5.4) CWE-264 vulnerability in moin. A fix is available for moin — see the affected versions and patch details below.
MoinMoin Improper Access Control
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
moinReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects PyPI packages — download data is not available via public APIs for these ecosystems.
Description
security/__init__.py in MoinMoin 1.9 through 1.9.4 does not properly handle group names that contain virtual group names such as "All," "Known," or "Trusted," which allows remote authenticated users with virtual group membership to be treated as a member of the group.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐍PyPI | moin | ≥ 1.9&&< 1.9.5 | 1.9.5pip install --upgrade 'moin==1.9.5' |
Affected Products
moinmoinmoinmoDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for moin, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update moin to 1.9.5 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2012-4404 is resolved across your whole dependency graph.
Workarounds
If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.
Fixing This On Your OS
If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.
Frequently Asked Questions
Is CVE-2012-4404 in your dependencies?
Find it across PyPI, including transitive dependencies.