NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐍
🐍 PyPI
Not in CISA KEV
MEDIUM severity

CVE-2016-7146 — moin

MEDIUM

CVE-2016-7146 is a medium-severity (CVSS 6.1) Cross-site Scripting (XSS) vulnerability in moin. 1 public exploit or proof-of-concept reference is indexed, so weaponization risk is real. A fix is available for moin — see the affected versions and patch details below.

MoinMoin Cross-site Scripting (XSS) vulnerability

Also known asPYSEC-2016-30
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
1 known
Exploitation data as of Nov 1, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
1.2%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs68th percentile — riskier than 68% of all scored CVEsHighest risk
0.00%0.57%1.13%1.70%0.3%1.2%May 26Aug 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected
🐍moin

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects PyPI packages — download data is not available via public APIs for these ecosystems.

Description

MoinMoin 1.9.8 allows remote attackers to conduct "JavaScript injection" attacks by using the "page creation or crafted URL" approach, related to a "Cross Site Scripting (XSS)" issue affecting the action=fckdialog&dialog=attachment (via page name) component.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
🐍PyPImoin≥ 1.9.8&&< 1.9.91.9.9pip install --upgrade 'moin==1.9.9'

Affected Products

1 product · 1 configurations
Application
moinmoinmoinmo
1 version
1.9.8
Exploits & PoCs
1

Research use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for moin, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update moin to 1.9.9 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2016-7146 is resolved across your whole dependency graph.

  3. Workarounds

    Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.

Fixing This On Your OS

If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.

UbuntuMEDIUM

Frequently Asked Questions

MoinMoin 1.9.8 allows remote attackers to conduct "JavaScript injection" attacks by using the "page creation or crafted URL" approach, related to a "Cross Site Scripting (XSS)" issue affecting the `action=fckdialog&dialog=attachment` (via page name) component.
O3 Security · Impact-Aware SCA

Is CVE-2016-7146 in your dependencies?

Find it across PyPI, including transitive dependencies.

CVE-2016-7146: moin XSS — Fixed in 1.9.9