NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐍
🐍 PyPI
Not in CISA KEV
MEDIUM severity

CVE-2016-9119 — moin

MEDIUM

CVE-2016-9119 is a medium-severity (CVSS 6.1) Cross-site Scripting (XSS) vulnerability in moin. A fix is available for moin — see the affected versions and patch details below.

MoinMoin Cross-site Scripting (XSS) vulnerability

Also known asPYSEC-2017-20
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
None indexed
Exploitation data as of Nov 4, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
1.5%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs74th percentile — riskier than 74% of all scored CVEsHighest risk
0.31%0.86%1.41%1.96%0.8%1.5%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected
🐍moin

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects PyPI packages — download data is not available via public APIs for these ecosystems.

Description

Cross-site scripting (XSS) vulnerability in the link dialogue in GUI editor in MoinMoin before 1.9.8 allows remote attackers to inject arbitrary web script or HTML via unspecified vectors.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
🐍PyPImoinall versions1.9.8pip install --upgrade 'moin==1.9.8'

Affected Products

3 products · 6 configurations
OS
ubuntu linuxcanonical
4 versions
12.0414.0416.0416.10
OS
debian linuxdebian
1 version
8.0
Application
moinmoinmoinmo
≤ 1.9.7
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for moin, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update moin to 1.9.8 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2016-9119 is resolved across your whole dependency graph.

  3. Workarounds

    Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.

Frequently Asked Questions

Cross-site scripting (XSS) vulnerability in the link dialogue in GUI editor in MoinMoin before 1.9.8 allows remote attackers to inject arbitrary web script or HTML via unspecified vectors.
O3 Security · Impact-Aware SCA

Is CVE-2016-9119 in your dependencies?

Find it across PyPI, including transitive dependencies.

CVE-2016-9119: moin XSS — Fixed in 1.9.8