Ansible-Core vulnerable to content protections bypassGHSA-99w6-3xph-cx78
MEDIUMFix: ansible/ansible#84299GHSA-99w6-3xph-cx78 is a medium-severity (CVSS 5.5) Improper Input Validation vulnerability in ansible-core. A fix is available for ansible-core — see the affected versions and patch details below.
Exploitation Status
No confirmed exploitation observed yet
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for GHSA-99w6-3xph-cx78.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
ansible-core🐍ansible-core🐍ansible-coreReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects PyPI packages — download data is not available via public APIs for these ecosystems.
Description
A flaw was found in Ansible-Core. This vulnerability allows attackers to bypass unsafe content protections using the hostvars object to reference and execute templated content. This issue can lead to arbitrary code execution if remote data or module outputs are improperly templated within playbooks.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐍PyPI | ansible-core | ≥ 2.18.0b1&&< 2.18.1rc1 | 2.18.1rc1pip install --upgrade 'ansible-core==2.18.1rc1' |
| 🐍PyPI | ansible-core | ≥ 2.17.0b1&&< 2.17.7rc1 | 2.17.7rc1pip install --upgrade 'ansible-core==2.17.7rc1' |
| 🐍PyPI | ansible-core | all versions | 2.16.14rc1pip install --upgrade 'ansible-core==2.16.14rc1' |
Detection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for ansible-core, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update ansible-core to 2.18.1rc1 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-99w6-3xph-cx78 is resolved across your whole dependency graph.
Workarounds
If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.
Fixing This On Your OS
If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.
To mitigate this vulnerability, avoid using the hostvars object to reference content marked as !unsafe. Ensure that all remote data from modules or lookups is properly sanitized and validated before use in playbooks. Additionally, restrict access to inventory files and Ansible playbooks to trusted users to minimize exploitation risks.Source: Red Hat security advisory for GHSA-99w6-3xph-cx78 (CC BY 4.0)
| Product | Fixed in | Advisory |
|---|---|---|
| Ansible Automation Platform Execution Environments | ansible-automation-platform/ansible-builder-rhel8:1.2.0-93 | RHSA-2024:10770 |
| Red Hat Ansible Automation Platform 2.5 for RHEL 8 | ansible-core-1:2.16.14-1.el8ap | RHSA-2024:11145 |
Frequently Asked Questions
Is GHSA-99w6-3xph-cx78 in your dependencies?
Find it across PyPI, including transitive dependencies.