CVE-2024-9902 is a medium-severity (CVSS 6.3) CWE-863 vulnerability in ansible-core. A fix is available for ansible-core — see the affected versions and patch details below.
Ansible-core: ansible-core user may read/write unauthorized content
Exploitation Status
No confirmed exploitation observed yet
- A successful exploit gives an attacker total control of the affected component, not partial access.
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for CVE-2024-9902.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
ansible-core🐍ansible-core🐍ansible-core🐍ansible-core🐍ansible-coreReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects PyPI packages — download data is not available via public APIs for these ecosystems.
Description
A flaw was found in Ansible. The ansible-core user module can allow an unprivileged user to silently create or replace the contents of any file on any system path and take ownership of it when a privileged user executes the user module against the unprivileged user's home directory. If the unprivileged user has traversal permissions on the directory containing the exploited target file, they retain full control over the contents of the file as its owner.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐍PyPI | ansible-core | all versions | 2.14.18rc1pip install --upgrade 'ansible-core==2.14.18rc1' |
| 🐍PyPI | ansible-core | ≥ 2.15.0b1&&< 2.15.13rc1 | 2.15.13rc1pip install --upgrade 'ansible-core==2.15.13rc1' |
| 🐍PyPI | ansible-core | ≥ 2.16.0b1&&< 2.16.13rc1 | 2.16.13rc1pip install --upgrade 'ansible-core==2.16.13rc1' |
| 🐍PyPI | ansible-core | ≥ 2.17.0b1&&< 2.17.6rc1 | 2.17.6rc1pip install --upgrade 'ansible-core==2.17.6rc1' |
| 🐍PyPI | ansible-core | ≥ 2.18.0b1&&< 2.18.0rc2 | 2.18.0rc2pip install --upgrade 'ansible-core==2.18.0rc2' |
Detection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for ansible-core, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update ansible-core to 2.14.18rc1 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2024-9902 is resolved across your whole dependency graph.
Workarounds
Put an independent control in front of the weakness: restrict the affected endpoint or interface to trusted networks, require an additional authentication factor or proxy-level check, and invalidate existing sessions and credentials in case the flaw has already been used.
Fixing This On Your OS
If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.
In the play that uses the user module with the key generation option, have a prior task ensuring the public key does not exist for example: - name: avoid user exploit (change name depending on other options used in user task) file: path=/home/{{username}}/.ssh/id_rsa.pub state=absentSource: Red Hat security advisory for CVE-2024-9902 (CC BY 4.0)
| Product | Fixed in | Advisory |
|---|---|---|
| Ansible Automation Platform Execution Environments | ansible-automation-platform/ansible-builder-rhel8:1.2.0-91 | RHSA-2024:8969 |
| Red Hat Ansible Automation Platform 2.4 for RHEL 8 | ansible-core-1:2.15.13-1.el8ap | RHSA-2024:10762 |
| Red Hat Ansible Automation Platform 2.5 for RHEL 8 | ansible-core-1:2.16.13-1.el8ap | RHSA-2024:9894 |
| Red Hat OpenStack Platform 17.1 for RHEL 9 | openstack-ansible-core-0:2.14.2-4.6.el9ost | RHSA-2025:1861 |
Frequently Asked Questions
Is CVE-2024-9902 in your dependencies?
Find it across PyPI, including transitive dependencies.