CVE-2023-5764 is a high-severity (CVSS 7.1) CWE-1336 vulnerability in ansible-core. A fix is available for ansible-core — see the affected versions and patch details below.
Ansible: template injection
Exploitation Status
No confirmed exploitation observed yet
- A successful exploit gives an attacker total control of the affected component, not partial access.
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for CVE-2023-5764.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
ansible-core🐍ansible-core🐍ansible-coreReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects PyPI packages — download data is not available via public APIs for these ecosystems.
Description
A template injection flaw was found in Ansible where a user's controller internal templating operations may remove the unsafe designation from template data. This issue could allow an attacker to use a specially crafted file to introduce templating injection when supplying templating data.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐍PyPI | ansible-core | ≥ 2.16.0&&< 2.16.1 | 2.16.1pip install --upgrade 'ansible-core==2.16.1' |
| 🐍PyPI | ansible-core | ≥ 2.15.0&&< 2.15.8 | 2.15.8pip install --upgrade 'ansible-core==2.15.8' |
| 🐍PyPI | ansible-core | all versions | 2.14.12pip install --upgrade 'ansible-core==2.14.12' |
Affected Products
extra packages for enterprise linuxfedoraprojectfedorafedoraprojectansibleredhatansible automation platformredhatansible developerredhatansible insideredhatDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for ansible-core, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update ansible-core to 2.16.1 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2023-5764 is resolved across your whole dependency graph.
Workarounds
If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.
Fixing This On Your OS
If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.
| Product | Fixed in | Advisory |
|---|---|---|
| Red Hat Ansible Automation Platform 2.4 for RHEL 8 | ansible-core-1:2.15.8-1.el8ap | RHSA-2023:7773 |
Frequently Asked Questions
Is CVE-2023-5764 in your dependencies?
Find it across PyPI, including transitive dependencies.