NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐍
🐍 PyPI
Not in CISA KEV
MEDIUM severity

Ansible template injection vulnerabilityGHSA-7j69-qfc3-2fq9

MEDIUMFix: ansible/ansible@270b39f

GHSA-7j69-qfc3-2fq9 is a medium-severity (CVSS 6.6) CWE-1336 vulnerability in ansible-core. A fix is available for ansible-core — see the affected versions and patch details below.

Also known asCVE-2023-5764PYSEC-2026-1122
Published
Updated
Affected
3 pkgs
Patched
3 / 3
Exploits
None indexed
Exploitation data as of Nov 4, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

Exploitation Status

No confirmed exploitation observed yet

  • A successful exploit gives an attacker total control of the affected component, not partial access.
  • CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.

Exploitation and automatability from CISA’s SSVC triage for GHSA-7j69-qfc3-2fq9.

EPSS Exploitation Probability

via FIRST.org ↗
0.6%probability of exploitation in next 30 days
Lower Risk+0.03%
Lower risk than most CVEs47th percentile — riskier than 47% of all scored CVEsHighest risk
0.00%0.36%0.72%1.07%0.1%0.6%May 26Aug 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

3 pkgs affected
🐍ansible-core🐍ansible-core🐍ansible-core

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects PyPI packages — download data is not available via public APIs for these ecosystems.

Description

A template injection flaw was found in Ansible where a user's controller internal templating operations may remove the unsafe designation from template data. This issue could allow an attacker to use a specially crafted file to introduce templating injection when supplying templating data.

Affected Packages

3 total 3 fixed
EcosystemPackageVulnerable rangeFix
🐍PyPIansible-core≥ 2.16.0&&< 2.16.12.16.1pip install --upgrade 'ansible-core==2.16.1'
🐍PyPIansible-core≥ 2.15.0&&< 2.15.82.15.8pip install --upgrade 'ansible-core==2.15.8'
🐍PyPIansible-coreall versions2.14.12pip install --upgrade 'ansible-core==2.14.12'

Affected Products

6 products · 12 configurations
Application
extra packages for enterprise linuxfedoraproject
1 version
8.0
OS
fedorafedoraproject
2 versions
3839
Application
ansibleredhat
≥ 2.15.0 && < 2.15.7
1 version
2.16.0
Application
ansible automation platformredhat
1 version
2.4
Application
ansible developerredhat
1 version
1.1
Application
ansible insideredhat
1 version
1.2

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for ansible-core, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update ansible-core to 2.16.1 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-7j69-qfc3-2fq9 is resolved across your whole dependency graph.

  3. Workarounds

    If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.

Fixing This On Your OS

If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.

Red HatModerate
ProductFixed inAdvisory
Red Hat Ansible Automation Platform 2.4 for RHEL 8ansible-core-1:2.15.8-1.el8apRHSA-2023:7773

Frequently Asked Questions

A template injection flaw was found in Ansible where a user's controller internal templating operations may remove the unsafe designation from template data. This issue could allow an attacker to use a specially crafted file to introduce templating injection when supplying templating data.
O3 Security · Impact-Aware SCA

Is GHSA-7j69-qfc3-2fq9 in your dependencies?

Find it across PyPI, including transitive dependencies.

Ansible template injection vulnerability (Medium 6.6)