NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐍
🐍 PyPI
Not in CISA KEV
MEDIUM severity

CVE-2024-11079 — ansible-core

MEDIUMFix: ansible/ansible#84299

CVE-2024-11079 is a medium-severity (CVSS 5.5) Improper Input Validation vulnerability in ansible-core. A fix is available for ansible-core — see the affected versions and patch details below.

Ansible-core: unsafe tagging bypass via hostvars object in ansible-core

Also known asGHSA-99w6-3xph-cx78PYSEC-2026-1123
Published
Updated
Affected
3 pkgs
Patched
3 / 3
Exploits
None indexed
Exploitation data as of Oct 30, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

Exploitation Status

No confirmed exploitation observed yet

  • CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.

Exploitation and automatability from CISA’s SSVC triage for CVE-2024-11079.

EPSS Exploitation Probability

via FIRST.org ↗
0.5%probability of exploitation in next 30 days
Lower Risk+0.03%
Lower risk than most CVEs45th percentile — riskier than 45% of all scored CVEsHighest risk
0.00%0.34%0.69%1.03%0.0%0.5%Apr 26Aug 26Oct 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

3 pkgs affected
🐍ansible-core🐍ansible-core🐍ansible-core

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects PyPI packages — download data is not available via public APIs for these ecosystems.

Description

A flaw was found in Ansible-Core. This vulnerability allows attackers to bypass unsafe content protections using the hostvars object to reference and execute templated content. This issue can lead to arbitrary code execution if remote data or module outputs are improperly templated within playbooks.

Affected Packages

3 total 3 fixed
EcosystemPackageVulnerable rangeFix
🐍PyPIansible-core≥ 2.18.0b1&&< 2.18.1rc12.18.1rc1pip install --upgrade 'ansible-core==2.18.1rc1'
🐍PyPIansible-core≥ 2.17.0b1&&< 2.17.7rc12.17.7rc1pip install --upgrade 'ansible-core==2.17.7rc1'
🐍PyPIansible-coreall versions2.16.14rc1pip install --upgrade 'ansible-core==2.16.14rc1'

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for ansible-core, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update ansible-core to 2.18.1rc1 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2024-11079 is resolved across your whole dependency graph.

  3. Workarounds

    If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.

Fixing This On Your OS

If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.

Red HatModerate
Workaround published by Red Hat
To mitigate this vulnerability, avoid using the hostvars object to reference content marked as !unsafe. Ensure that all remote data from modules or lookups is properly sanitized and validated before use in playbooks. Additionally, restrict access to inventory files and Ansible playbooks to trusted users to minimize exploitation risks.
Source: Red Hat security advisory for CVE-2024-11079 (CC BY 4.0)
ProductFixed inAdvisory
Ansible Automation Platform Execution Environmentsansible-automation-platform/ansible-builder-rhel8:1.2.0-93RHSA-2024:10770
Red Hat Ansible Automation Platform 2.5 for RHEL 8ansible-core-1:2.16.14-1.el8apRHSA-2024:11145

Frequently Asked Questions

A flaw was found in Ansible-Core. This vulnerability allows attackers to bypass unsafe content protections using the hostvars object to reference and execute templated content. This issue can lead to arbitrary code execution if remote data or module outputs are improperly templated within playbooks.
O3 Security · Impact-Aware SCA

Is CVE-2024-11079 in your dependencies?

Find it across PyPI, including transitive dependencies.

CVE-2024-11079: ansible-core RCE — Fixed in 2.18.1rc1