CVE-2024-0690 is a medium-severity (CVSS 5) CWE-117 vulnerability in ansible-core. A fix is available for ansible-core — see the affected versions and patch details below.
Ansible-core: possible information leak in tasks that ignore ansible_no_log configuration
Exploitation Status
No confirmed exploitation observed yet
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for CVE-2024-0690.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
ansible-core🐍ansible-core🐍ansible-coreReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects PyPI packages — download data is not available via public APIs for these ecosystems.
Description
An information disclosure flaw was found in ansible-core due to a failure to respect the ANSIBLE_NO_LOG configuration in some scenarios. It was discovered that information is still included in the output in certain tasks, such as loop items. Depending on the task, this issue may include sensitive information, such as decrypted secret values.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐍PyPI | ansible-core | all versions | 2.14.14pip install --upgrade 'ansible-core==2.14.14' |
| 🐍PyPI | ansible-core | ≥ 2.16.0&&< 2.16.3 | 2.16.3pip install --upgrade 'ansible-core==2.16.3' |
| 🐍PyPI | ansible-core | ≥ 2.15.0&&< 2.15.9 | 2.15.9pip install --upgrade 'ansible-core==2.15.9' |
Affected Products
fedorafedoraprojectansibleredhatansible automation platformredhatansible developerredhatansible insideredhatenterprise linuxredhatDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for ansible-core, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update ansible-core to 2.14.14 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2024-0690 is resolved across your whole dependency graph.
Workarounds
Assume what was exposed is already known: rotate any credential, token or key that the affected component could return, restrict the endpoint to callers that genuinely need it, and strip sensitive fields from responses and error output at the boundary rather than relying on the client not to read them.
Fixing This On Your OS
If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.
Explicitly setting 'no_log' within the playbook will prevent the output from containing potentially sensitive information.Source: Red Hat security advisory for CVE-2024-0690 (CC BY 4.0)
| Product | Fixed in | Advisory |
|---|---|---|
| Red Hat Ansible Automation Platform 2.4 for RHEL 8 | ansible-core-1:2.15.9-1.el8ap | RHSA-2024:0733 |
| Red Hat Enterprise Linux 8 | ansible-core-0:2.16.3-2.el8 | RHSA-2024:3043 |
| Red Hat Enterprise Linux 9 | ansible-core-1:2.14.14-1.el9 | RHSA-2024:2246 |
Frequently Asked Questions
Is CVE-2024-0690 in your dependencies?
Find it across PyPI, including transitive dependencies.