NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐘
🐘 Packagist
Not in CISA KEV
HIGH severity

Wikimedia MediaWiki allows CSRFGHSA-27fw-r78j-h898

HIGH

GHSA-27fw-r78j-h898 is a high-severity (CVSS 8.8) Cross-Site Request Forgery (CSRF) vulnerability in mediawiki/core. A fix is available for mediawiki/core — see the affected versions and patch details below.

Also known asCVE-2019-12466
Published
Updated
Affected
4 pkgs
Patched
4 / 4
Exploits
None indexed
Exploitation data as of Nov 3, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
0.8%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs58th percentile — riskier than 58% of all scored CVEsHighest risk
0.00%0.45%0.90%1.35%0.2%0.8%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

4 pkgs affected
🐘mediawiki/core🐘mediawiki/core🐘mediawiki/core🐘mediawiki/core

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.

Description

Wikimedia MediaWiki through 1.32.1 allows CSRF in logout feature.

Affected Packages

4 total 4 fixed
EcosystemPackageVulnerable rangeFix
🐘Packagistmediawiki/core≥ 1.27.0&&< 1.27.61.27.6composer require mediawiki/core:^1.27.6
🐘Packagistmediawiki/core≥ 1.30.0&&< 1.30.21.30.2composer require mediawiki/core:^1.30.2
🐘Packagistmediawiki/core≥ 1.31.0&&< 1.31.21.31.2composer require mediawiki/core:^1.31.2
🐘Packagistmediawiki/core≥ 1.32.0&&< 1.32.21.32.2composer require mediawiki/core:^1.32.2

Affected Products

2 products · 2 configurations
OS
debian linuxdebian
1 version
9.0
Application
mediawikimediawiki
≤ 1.32.1
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for mediawiki/core, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update mediawiki/core to 1.27.6 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-27fw-r78j-h898 is resolved across your whole dependency graph.

  3. Workarounds

    If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.

Frequently Asked Questions

Wikimedia MediaWiki through 1.32.1 allows CSRF in logout feature.
O3 Security · Impact-Aware SCA

Is GHSA-27fw-r78j-h898 in your dependencies?

Find it across Packagist, including transitive dependencies.

Wikimedia MediaWiki allows CSRF (High 8.8)