NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
☕ Maven
Not in CISA KEV

Improper Input Validation in Apache ActiveMQGHSA-23cr-5hr4-rgwv

Fix: apache/activemq@22f2f3d

GHSA-23cr-5hr4-rgwv is a CWE-255 vulnerability in org.apache.activemq:activemq-broker. A fix is available for org.apache.activemq:activemq-broker — see the affected versions and patch details below.

Also known asCVE-2015-6524
Published
Updated
Affected
2 pkgs
Patched
2 / 2
Exploits
None indexed
Exploitation data as of Nov 6, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
8.2%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs95th percentile — riskier than 95% of all scored CVEsHighest risk
0.00%3.60%7.20%10.8%1.2%8.2%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

Real-World Exposure

2 pkgs affected
☕org.apache.activemq:activemq-broker☕org.apache.activemq:activemq-jaas

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.

Description

The LDAPLoginModule implementation in the Java Authentication and Authorization Service (JAAS) in Apache ActiveMQ 5.x before 5.10.1 allows wildcard operators in usernames, which allows remote attackers to obtain credentials via a brute force attack. NOTE: this identifier was SPLIT from CVE-2014-3612 per ADT2 due to different vulnerability types.

Affected Packages

2 total 2 fixed
EcosystemPackageVulnerable rangeFix
☕Mavenorg.apache.activemq:activemq-broker≥ 5.0.0&&< 5.10.25.10.2org.apache.activemq:activemq-broker:5.10.2
☕Mavenorg.apache.activemq:activemq-jaas≥ 5.0.0&&< 5.10.25.10.2org.apache.activemq:activemq-jaas:5.10.2

Affected Products

2 products · 20 configurations
Application
activemqapache
18 versions
5.0.05.1.05.2.05.3.05.3.15.3.25.4.05.4.15.4.25.4.35.5.05.5.1
OS
fedorafedoraproject
2 versions
2223

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.apache.activemq:activemq-broker, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update org.apache.activemq:activemq-broker to 5.10.2 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-23cr-5hr4-rgwv is resolved across your whole dependency graph.

  3. Workarounds

    If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.

Frequently Asked Questions

The LDAPLoginModule implementation in the Java Authentication and Authorization Service (JAAS) in Apache ActiveMQ 5.x before 5.10.1 allows wildcard operators in usernames, which allows remote attackers to obtain credentials via a brute force attack. NOTE: this identifier was SPLIT from CVE-2014-3612 per ADT2 due to different vulnerability types.
O3 Security · Impact-Aware SCA

Is GHSA-23cr-5hr4-rgwv in your dependencies?

Find it across Maven, including transitive dependencies.

Improper Input Validation in Apache ActiveMQ